# Nginx cannot start after update

**URL:** https://forum.yunohost.org/t/nginx-cannot-start-after-update/18623
**Category:** Support
**Tags:** nginx, french, english
**Created:** [January 26, 2022, 10:49pm UTC](https://forum.yunohost.org/t/nginx-cannot-start-after-update/18623 "2022-01-26T22:49:53Z")
**Posts on this page:** 1
**Showing post:** 7

<div class="post-metadata">

### Author: ![bbateausurleau](https://forum.yunohost.org/user_avatar/forum.yunohost.org/bbateausurleau/32/5041_2.png) [@bbateausurleau](https://forum.yunohost.org/u/bbateausurleau)
#### Post date: [February 7, 2022, 11:48am UTC](https://forum.yunohost.org/t/nginx-cannot-start-after-update/18623/7 "2022-02-07T11:48:42Z")

</div>

> [@pigeontech](#):
>
> sudo apt-get reinstall nginx

salut,  
Suite à une intervention sur les serveurs d’ARN, il semble que je sois confronté au même problème…

Différentes commandes testées :

1. 

```auto
systemctl restart nginx

```

```auto
'See "systemctl status nginx.service" and "journalctl -xe" for details.
Warning: Could not execute the command 'systemctl restart nginx'
Error: Could not restart the service 'nginx'

Recent service logs:-- Logs begin at Sun 2022-02-06 10:28:29 UTC, end at Sun 2022-02-06 18:30:04 UTC. --
Feb 06 18:13:07 systemd[1]: Starting A high performance web server and a reverse proxy server...
Feb 06 18:14:37 systemd[1]: nginx.service: Start-pre operation timed out. Terminating.
Feb 06 18:14:37 systemd[1]: nginx.service: Control process exited, code=killed, status=15/TERM
Feb 06 18:14:37 systemd[1]: nginx.service: Failed with result 'timeout'.
Feb 06 18:14:37 systemd[1]: Failed to start A high performance web server and a reverse proxy server.
Feb 06 18:26:12 systemd[1]: Starting A high performance web server and a reverse proxy server...
Feb 06 18:27:42 systemd[1]: nginx.service: Start-pre operation timed out. Terminating.
Feb 06 18:27:42 systemd[1]: nginx.service: Control process exited, code=killed, status=15/TERM
Feb 06 18:27:42 systemd[1]: nginx.service: Failed with result 'timeout'.
Feb 06 18:27:42 systemd[1]: Failed to start A high performance web server and a reverse proxy server.'

```

1. 

`yunohost tools regen-conf --with-diff --dry-run nginx`

Pas de réponse…

```auto

3. 

```

df -h

````auto

```> Filesystem Size Used Avail Use% Mounted on
> udev 984M 0 984M 0% /dev
> tmpfs 200M 21M 179M 11% /run
> /dev/vda1 98G 48G 46G 51% /
> tmpfs 998M 132K 998M 1% /dev/shm
> tmpfs 5.0M 0 5.0M 0% /run/lock
> tmpfs 998M 0 998M 0% /sys/fs/cgroup```

4. 

````

free -m

```auto
> total used free shared buff/cache available
> Mem: 1995 1226 205 22 562 589
> Swap: 1023 1023 0

```

1. 

```auto
systemctl restart nginx

```

> 1. Job for nginx.service failed because a timeout was exceeded. See “systemctl status nginx.service” and “journalctl -xe” for details.
> 2. sysstat is already the newest version (12.0.3-2)
> 3. root@fsu72:/# sudo iostat Linux 4.19.0-18-amd64 ([fsu72.fr](http://fsu72.fr/)) 02/06/2022 _x86\_64_ (1 CPU) avg-cpu: %user %nice %system %iowait %steal %idle 6.62 0.00 1.80 1.41 0.03 90.14 Device tps kB\_read/s kB\_wrtn/s kB\_read kB\_wrtn vda 5.86 41.44 74.12 1848189 3305644
> 4. [19:58](https://matrix.to/#/!YFdeIkoOufmCwTLkmX:matrix.fdn.fr/$vIrR4_JKEqYKFxrAJSajaFt7Hmy_0WK1IfnZsYJ0TW8?via=sans-nuage.fr&via=matrix.fdn.fr&via=matrix.org)  
> le ‘90.14’ est en rouge.

1. systemctl status nginx.service

```auto
systemctl status nginx.service

```

> ● nginx.service - A high performance web server and a reverse proxy server Loaded: loaded (/lib/systemd/system/nginx.service; enabled; vendor preset: enabled) Active: failed (Result: timeout) since Sun 2022-02-06 18:57:08 UTC; 3min 31s ago Docs: man:nginx(8) Process: 27326 ExecStartPre=/usr/sbin/nginx -t -q -g daemon on; master\_process on; (code=killed, signal Feb 06 18:55:38 [fsu72.fr](http://fsu72.fr/) systemd[1]: Starting A high performance web server and a reverse proxy server… Feb 06 18:57:08 [fsu72.fr](http://fsu72.fr/) systemd[1]: nginx.service: Start-pre operation timed out. Terminating. Feb 06 18:57:08 [fsu72.fr](http://fsu72.fr/) systemd[1]: nginx.service: Control process exited, code=killed, status=15/TERM Feb 06 18:57:08 [fsu72.fr](http://fsu72.fr/) systemd[1]: nginx.service: Failed with result ‘timeout’. Feb 06 18:57:08 [fsu72.fr](http://fsu72.fr/) systemd[1]: Failed to start A high performance web server and a reverse proxy se

1. 

```auto
cat /root/test

```

> test

1. 

```auto

```

journalctl -u ngnix

```auto

> -- Logs begin at Sun 2022-02-06 10:28:29 UTC, end at Sun 2022-02-06 19:09:32 UTC. -- Feb 06 18:13:07 [fsu72.fr](http://fsu72.fr/) systemd[1]: Starting A high performance web server and a reverse proxy server... Feb 06 18:14:37 [fsu72.fr](http://fsu72.fr/) systemd[1]: nginx.service: Start-pre operation timed out. Terminating. Feb 06 18:14:37 [fsu72.fr](http://fsu72.fr/) systemd[1]: nginx.service: Control process exited, code=killed, status=15/TERM Feb 06 18:14:37 [fsu72.fr](http://fsu72.fr/) systemd[1]: nginx.service: Failed with result 'timeout'. Feb 06 18:14:37 [fsu72.fr](http://fsu72.fr/) systemd[1]: Failed to start A high performance web server and a reverse proxy se Feb 06 18:26:12 [fsu72.fr](http://fsu72.fr/) systemd[1]: Starting A high performance web server and a reverse proxy server... Feb 06 18:27:42 [fsu72.fr](http://fsu72.fr/) systemd[1]: nginx.service: Start-pre operation timed out. Terminating. Feb 06 18:27:42 [fsu72.fr](http://fsu72.fr/) systemd[1]: nginx.service: Control process exited, code=killed, status=15/TERM Feb 06 18:27:42 [fsu72.fr](http://fsu72.fr/) systemd[1]: nginx.service: Failed with result 'timeout'. Feb 06 18:27:42 [fsu72.fr](http://fsu72.fr/) systemd[1]: Failed to start A high performance web server and a reverse proxy se Feb 06 18:30:46 [fsu72.fr](http://fsu72.fr/) systemd[1]: Starting A high performance web server and a reverse proxy server... Feb 06 18:32:17 [fsu72.fr](http://fsu72.fr/) systemd[1]: nginx.service: Start-pre operation timed out. Terminating. Feb 06 18:32:17 [fsu72.fr](http://fsu72.fr/) systemd[1]: nginx.service: Control process exited, code=killed, status=15/TERM Feb 06 18:32:17 [fsu72.fr](http://fsu72.fr/) systemd[1]: nginx.service: Failed with result 'timeout'. Feb 06 18:32:17 [fsu72.fr](http://fsu72.fr/) systemd[1]: Failed to start A high performance web server and a reverse proxy se Feb 06 18:55:32 [fsu72.fr](http://fsu72.fr/) systemd[1]: Starting A high performance web server and a reverse proxy server... Feb 06 18:55:38 [fsu72.fr](http://fsu72.fr/) systemd[1]: nginx.service: Control process exited, code=killed, status=15/TERM Feb 06 18:55:38 [fsu72.fr](http://fsu72.fr/) systemd[1]: nginx.service: Succeeded. Feb 06 18:55:38 [fsu72.fr](http://fsu72.fr/) systemd[1]: Stopped A high performance web server and a reverse proxy server. Feb 06 18:55:38 [fsu72.fr](http://fsu72.fr/) systemd[1]: Starting A high performance web server and a reverse proxy server... Feb 06 18:57:08 [fsu72.fr](http://fsu72.fr/) systemd[1]: nginx.service: Start-pre operation timed out. Terminating. Feb 06 18:57:08 [fsu72.fr](http://fsu72.fr/) systemd[1]: nginx.service: Control process exited, code=killed, status=15/TERM Feb 06 18:57:08 [fsu72.fr](http://fsu72.fr/) systemd[1]: nginx.service: Failed with result 'timeout'. Feb 06 18:57:08 [fsu72.fr](http://fsu72.fr/) systemd[1]: Failed to start A high performance web server and a reverse proxy se

9.

```

ps aux | grep nginx

```auto

>root 28501 0.0 0.0 6144 884 pts/0 S+ 19:10 0:00 grep nginx

10.

```

usr/sbin/nginx -t -q -g ‘daemon on; master\_process on;’

```auto
>Pas de réponse.

11.

```

fuser -k 80/tcp  
fuser -k 443/tcp

```auto

>Pas de réponse

12.

```

dpkg -l | grep apache

```auto

>Pas de réponse

13.

```

systemctl start nginx

```auto

> 1. Job for nginx.service failed because a timeout was exceeded. See "systemctl status nginx.service" and "journalctl -xe" for details.

14. 

```

yunohost app list

```auto

> apps: 
> 0: 
> description: Zero Knowledge realtime collaborative editor
> domain_path: cryptpad.fsu72.fr/
> id: cryptpad
> name: CryptPad
> version: 4.12.0~ynh1
> 1: 
> description: Online editor providing collaborative editing in real-time
> domain_path: fsu72.fr/pad
> id: etherpad_mypads
> name: Etherpad
> version: 1.8.16~ynh2
> 2: 
> description: Next-generation forum made simple
> domain_path: forum.fsu72.fr/
> id: flarum
> name: Forum
> version: 1.2.0~ynh1
> 3: 
> description: URL Shortener
> domain_path: fsu72.fr/lstu
> id: lstu
> name: Lstu
> version: 0.23-0~ynh1
> 4: 
> description: Self hosting files and sharing anonymous application
> domain_path: lufi.fsu72.fr/
> id: lufi
> name: Lufi
> version: 0.05.16~ynh1
> 5: 
> description: Online storage, file sharing platform and various other applications
> domain_path: fsu72.fr/nextcloud
> id: nextcloud
> name: Nextcloud
> version: 22.2.3~ynh1
> 6: 
> description: Create and edit documents collaboratively
> domain_path: onlyoffice.fsu72.fr/
> id: onlyoffice
> name: OnlyOffice
> version: 6.4.0~ynh2
> 7: 
> description: Service for planning an appointment or making a decision quickly and easily
> domain_path: date.fsu72.fr/
> id: opensondage
> name: Date
> version: 1.1.17~ynh1
> 8: 
> description: Trello-like kanban
> domain_path: fsu72.fr/wekan
> id: wekan
> name: Wekan
> version: 5.93~ynh1

15.

```

netstat -tulpn | grep 80

```auto
> tcp 0 0 127.0.0.1:8024 0.0.0.0:* LISTEN 2140/python3        
> tcp 0 0 0.0.0.0:8095 0.0.0.0:* LISTEN 455/node            
> tcp 0 0 127.0.0.1:8096 0.0.0.0:* LISTEN 1616/lufi           
> tcp 0 0 127.0.0.1:8097 0.0.0.0:* LISTEN 2144/python3        
> tcp 0 0 127.0.0.1:8098 0.0.0.0:* LISTEN 1607/lstu           
> tcp6 0 0 :::8000 :::* LISTEN 1027/docservice     
> udp6 0 0 fe80::a800:ff:feee::123 :::* 416/ntpd

```

1. 

```auto
/usr/sbin/nginx -t -g 'master_process on;'

```

> nginx: the configuration file /etc/nginx/nginx.conf syntax is ok  
> nginx: configuration file /etc/nginx/nginx.conf test is successful

1. 

```auto
yunohost settings get security.nginx.compatibility

```

> intermediate

1. 

```auto
ps aux | grep nginx

```

> root 31744 0.0 0.0 6144 888 pts/0 R+ 19:49 0:00 grep nginx

1. 

```auto
systemctl start nginx

```

> Job for nginx.service failed because a timeout was exceeded.  
> See “systemctl status nginx.service” and “journalctl -xe” for details.

1. 

```auto
tail -n150 /var/log/nginx/error.log

```

> 2022/02/06 07:03:09 [info] 4905#4905: Using 32768KiB of shared memory for nchan in /etc/nginx/nginx.conf:63  
> 2022/02/06 18:14:37 [info] 23663#23663: Using 32768KiB of shared memory for nchan in /etc/nginx/nginx.conf:63  
> 2022/02/06 18:27:42 [info] 24605#24605: Using 32768KiB of shared memory for nchan in /etc/nginx/nginx.conf:63  
> 2022/02/06 19:11:47 [info] 28647#28647: Using 32768KiB of shared memory for nchan in /etc/nginx/nginx.conf:63  
> 2022/02/06 19:34:55 [info] 30675#30675: Using 32768KiB of shared memory for nchan in /etc/nginx/nginx.conf:63  
> 2022/02/06 19:42:05 [info] 31230#31230: Using 32768KiB of shared memory for nchan in /etc/nginx/nginx.conf:63

1. 

```auto
systemctl restart nginx

```

> Job for nginx.service failed because a timeout was exceeded.  
> See “systemctl status nginx.service” and “journalctl -xe” for details.

1. 

```auto
systemctl status nginx.service

```

> ● nginx.service - A high performance web server and a reverse proxy server  
> Loaded: loaded (/lib/systemd/system/nginx.service; enabled; vendor preset: enabled)  
> Active: failed (Result: timeout) since Mon 2022-02-07 11:45:05 UTC; 2min 55s ago  
> Docs: man:nginx(8)  
> Process: 4194 ExecStartPre=/bin/true (code=exited, status=0/SUCCESS)  
> Process: 4195 ExecStartPre=/usr/sbin/nginx -t -q -g daemon on; master\_process on; (code=killed

Feb 07 11:43:35 [fsu72.fr](http://fsu72.fr) systemd[1]: Starting A high performance web server and a reverse proxy  
Feb 07 11:45:05 [fsu72.fr](http://fsu72.fr) systemd[1]: nginx.service: Start-pre operation timed out. Terminating.  
Feb 07 11:45:05 [fsu72.fr](http://fsu72.fr) systemd[1]: nginx.service: Control process exited, code=killed, status=  
Feb 07 11:45:05 [fsu72.fr](http://fsu72.fr) systemd[1]: nginx.service: Failed with result ‘timeout’.  
Feb 07 11:45:05 [fsu72.fr](http://fsu72.fr) systemd[1]: Failed to start A high performance web server and a reverse

**À cette heure, je suis sans solution !!!**

---

_[View the full topic](https://forum.yunohost.org/t/nginx-cannot-start-after-update/18623)._
