Nextcloud update 22.2.10~ynh1 to 24.0.4~ynh1 fails

My YunoHost server

Hardware: privat server at home
YunoHost version: 11.0.9.14
I have access to my server : Through SSH and through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

Hi,
when i try to update nextcloud to 24.0.4 it fails an i can’t figure out where the problem is. I hope that my logs can help to solve this issue. if i can help with some actions on my server please reach back to me.

https://paste.yunohost.org/raw/wukizemice this is the log file after i tryed to update.

thanks in advance

fichte

1 Like

I am about to upgrade, so I came here because I am not sure if upgrading Nextcloud from 22 to 24 is possible and wonder why 23 is skipped. Maybe this is not a problem, but I thought it is needed to upgrade from a major version to the next.

Anyway, I hope you get some replies.

Here in the Nextcloud docu it also states:

You cannot skip major releases. Please re-run the upgrade until you have reached the highest available (or applicable) release.

Source here

i have seen in my log that there is first a update to 23.0.0 and then the script trys to update to 24.0.4

Yes, the upgrade script upgrades to all major versions before upgrading to the last one.

cf. nextcloud_ynh/upgrade at 0d102edec98fbb6c0518d850b01dfcb4b7079289 · YunoHost-Apps/nextcloud_ynh · GitHub

@fichte This issue may be caused by an unsupported installed app… try to disable non standard apps first before upgrading.

1 Like

thanks for this confirmation!

I had some of the featured apps installed and two (Bookmarks and Breeze Dark) that are not “featured” and i tried to deactivate them and then update but no changes.

In my case it was full text search.

Did you checked that your NC (or PHP) config files have appropriate permissions?

2022-09-13 20:04:38,854: WARNING - In Config.php line 298:
2022-09-13 20:04:38,855: DEBUG - 
2022-09-13 20:04:38,855: WARNING -   Config is set to be read-only via option "config_is_read_only".

I’m just guessing. And since Nc checked that it’s root, it shouldn’t be the problem. But what if it respects some internal Nc option?

I can confirm! Same problem, same solution as @petesim . Thank you!

For me it was the mail app (even though it is a featured app). When I wanted to try again a few days later, I noticed that some updates were available for the mail app, so I first updated all the nextcloud apps, then upgraded nextcloud (without de-activating any app), and the upgrade went smoothly.

Hello :raised_back_of_hand:
i got an issue quite similar…
I suspect this in my log :slight_smile:

2022-09-26 16:46:54,560: DEBUG - This version of Nextcloud is not compatible with > PHP 7.4.
You are currently running 8.0.23.+ ynh_exit_properly
2022-09-26 16:46:54,560: DEBUG - + local exit_code=255
2022-09-26 16:46:54,561: DEBUG - + ‘[’ 255 -eq 0 ‘]’
2022-09-26 16:46:55,063: DEBUG - + ynh_clean_setup
2022-09-26 16:46:55,063: DEBUG - + ynh_restore_upgradebackup
2022-09-26 16:46:55,063: DEBUG - + ynh_print_err ‘–message=Upgrade failed.’
2022-09-26 16:46:55,074: DEBUG - + ynh_print_log ‘[Error] Upgrade failed.’
2022-09-26 16:46:55,075: DEBUG - + echo -e ‘[Error] Upgrade failed.’
2022-09-26 16:46:55,075: DEBUG - + local app_bck=nextcloud
2022-09-26 16:46:55,075: DEBUG - + NO_BACKUP_UPGRADE=0
2022-09-26 16:46:55,076: WARNING - [Error] Upgrade failed.
2022-09-26 16:46:55,076: DEBUG - + ynh_backup_archive_exists nextcloud-pre-upgrade1
2022-09-26 16:46:55,076: DEBUG - + yunohost backup list --output-as json --quiet
2022-09-26 16:46:55,076: DEBUG - + jq -e --arg archive nextcloud-pre-upgrade1 ‘.archives | index($archive)’

Complete log there: https://paste.yunohost.org/raw/hocomulica

Thanks for helping…
#nextcloud

hey guys,

i have tried the things you all have done, but no changes at my server. The app full text search is not installed on my nextcloud. can i get some help to find out whats going on or how to fix my issue?

thanks in advance

fichte