Nextcloud not reachable after error while updating from 15.0.7 to 15.0.11

Hello there!

I’m new to the own-server-thing. And I’m really happy about it!
Yunohost is a great software! Until now everything went really smooth…

But now I’m stuck. While updating my Nextcloud app something went wrong and now I can’t get it back to work.

Can somebody please help me or point me in the right direction?

My YunoHost server

HP EliteBook 8560p with a Intel® Core™ i7 processor and 16 GiB memory

YunoHost version:

I have access to my server : Through SSH & through the webadmin

Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

I started the update process for my nextcloud app through the webadmin from 15.0.7 to 15.0.11. The update process stopped giving me the error message that it didn’t work. The system restored the old version of nextcloud as expected.

I can’t figure out what went wrong during the update process (I’m just learning to read the log files). Can somebody help me with that?

I can’t connect to the nextcloud instance although it should be the old version which did work before. What should I do to restore it?

These is the log:

This is the error I get when trying to connect to the Nextcloud web:
I think this is strange because it did work before…

Hmmm not sure exactly why this happens now … if you installed your server like 6 months ~ 1 year ago that might be an old issue which is solved for new setup but we didnt provide a clean fix for existing instance …

Anyway running this should do the trick: apt install php-zip

Hey Aleks

Thanks for your reply!

Unfortunally it didn’t do the trick… :frowning:

I installed php-zip and rebooted the computer (not only yunohost) but I still can’t enter Nextcloud. I still get the same message.

I also can’t see php-zip in the yunohost services. Does that matter? Is there a command I have to run, so that yunohost uses php-zip?

Hmm… I have installed yunohost around March/April 2019. Could that be the problem?

Not a problem per se, we can easily find a fix for your situation, please don’t start having crazy thoughts about reinstalling only for this :wink:

Nope, php-zip is just a package, not really a service, you don’t need to do anything in particular for the system to use it I believe …

What about apt install php7.0-zip, does that install another package …?

When you run dpkg --list | grep php7, do you see versions “7.0.33-0+deb9u5” ?

Perfect!!! It worked!

As info: It did install an other package. php-zip installed php7.3-zip, not php7.0-zip.

Thanks a lot for your help! :smiley:

(and thanks for releasing me from “having crazy thoughts about reinstalling only for this”! It only crossed my mind once or twice… :relaxed:)

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.