Nextcloud 25 is not 32 bits - Raspberry Pi 2B can't run it :'(

Which issue ?

This is exactly what happened :pensive:
I don’t how I could miss it… I have to reinstall everything now :roll_eyes:
Thanks a lot :+1:

The one described earlier in this thread.
My problem is now identified. It was my mistake, installing the 32bit version on my RPI4 :person_facepalming:

I did the same, I didn’t know they were a 64bits version… :frowning:

Wait for the news !

1 Like


Since 2016 and my first −and still running− Lime1, I thought it was a 64bit cpu.

Looking through the Yunohost Helpers, the running instance architecture is obtained with…

dpkg --print-architecture

And compared in the installation and upgrade code of Nextcloud_ynh

And the message Sorry, Nextcloud has deprecated 32-bit support tilted me.

I did not believed it first, may be a joke or a bug or something, but sadly not.

It is said on the Debian website about armhf that it’s a 32bit architecture.

I don’t know where I got this belief that it was 64bit and it bothers me to realize this after six years of using and recommending lime1 and lime2.

Next time, instead of using lscpu or uname -a or uname -m or even dpkg --print-architecture, I’ll also do a file /usr/bin/file who says…

file /usr/bin/file
/usr/bin/file: ELF 32-bit LSB shared object, ARM, EABI5 version …

On a 64-bit system it says…

file /usr/bin/file
/usr/bin/file: ELF 64-bit LSB pie executable, x86-64, version …

I feel sad.


Depuis ma première Lime1 de 2016 et qui fonctionne encore aujourd’hui, j’ai toujours cru que le CPU était un 64bit.

C’est au travers des Helpers de Yunohost que l’architecture est récupérée

Pour être comparée dans le code l’installation ou de mise à jour de Nextcloud

Et que le message Sorry, Nextcloud has deprecated 32-bit support m’a fait flipper.

J’y ai pas cru… je me suis dit que c’était une erreur ou une mauvaise blague, mais malheureusement…

dpkg --print-architecture

Et sur le site de Debian c’est dit que c’est du 32bit.

Je ne sais pas d’où je tiens cette croyance que c’était du 64bit et ça me fait bien chier d’en prendre conscience après six ans d’utilisation et de recommandation d’utilisation des lime1 et lime2.

À partir de maintenant, en plus de lscpu ou uname -a ou uname -m ou même dpkg --print-architecture, je vais aussi faire file /usr/bin/file qui dit…

file /usr/bin/file
/usr/bin/file: ELF 32-bit LSB shared object, ARM, EABI5 version …

Sur un système 64-bit ça dit…

file /usr/bin/file
/usr/bin/file: ELF 64-bit LSB pie executable, x86-64, version …

Je me sens triste.

A good news !!

We have to wait a moment :wink:
Yep, good news for the planet :slight_smile: Agree !


Where are we on the 32 support?
Do we know if the 32 support will arrive soon ?
For the moment the 24 version is still blocked at my place.

Have you tried to install testing?

1 Like

32 bit support is still there.
However, there were a bug in early Nextcloud 25.x versions with 32 bits and quotas.
Nextcloud 25.0.3 should have fixed it. For now it is in testing for Yunohost (you can try it if you want), and it should be soon (depends on testing !) released as a normal version.

This is what we can read on github

**[Gredin67](** [Jan 24, 2023]( •

My suggestion: "Nextcloud will deprecate 32-bit support within the next years. You should start thinking about upgrading to a 64-bit architecture.

Does anyone know when(/which version) it will become mandatory to switch from 32bit arch to 64bit ?

We don’t.
It was supposed to be 25.
Now it seems to be at least 26.
There is a debate in Nextcloud community about maintaining it longer.

The future will tell us :slight_smile:

1 Like

No I didn’t want to go to testing

@Lapineige I will wait for released. I’ll be patient.

1 Like

The funny thing is, we need user to test before merging… and nobody is willing to test and prefer waiting for the released version… I bet you can expect the master branch to come with bugs :grimacing:


I didn’t understand that a user was needed to test this version. Either it was said above or it wasn’t made clear.
I’m willing to test, but I don’t feel very comfortable with the system and I’m a bit afraid of ending up with an unusable Nextcloud in production, when my family needs it daily. I don’t have a test machine.
I do understand the human need to help with development, testing etc. I already participate in the QA of Mageia Linux, where I have a test machine reserved for that and where I also feel more autonomous to help me out. I don’t do this on my production machine.
Now if the community is ready to give me support I’m willing to test this version. But I’ll have to go step by step with me, starting with how to get through the testing branch to download the desired version.

We need more contributors yes, but it’s understandable people are not willing to beta test something on a production server :slight_smile:

I tested the upgrade in 3 servers, the Continuous Integration test is happy, and it’s not a massive change, for my part I think it is not a big risk to merge as it is :slight_smile:

If someone is willing to test this testing branch version, you will have to do it like this:

  • connect to the command line interface (via SSH) to your Yunohost server
  • Then use this command : sudo yunohost app upgrade nextcloud -u (note that if you have multiple Nextcloud installed, you might change the app name accordingly)
  • then check if Nextcloud is running correctly :slight_smile:

A backup (of the core, not the files) of Nextcloud will be created before the upgrade, but it is always good to have a general backup somewhere :slight_smile:

We mainly need 32bits testers here, to check if the quota bug is solved.

That said, I won’t push you to beta test this, even if the risk is small (in the worst case, you could revert to the previous backup, and in case of the Quota bug, patch it manually), if you don’t feel confortable with it, don’t do it, that’s fine :wink:

Hello @Lapineige,

I’ll try it. But let me a moment to have enought time at home without children to make this test.
I’ll be back to comment on the experience.

We merged it, so it’s now a normal upgrade :slight_smile: