Nextcloud 22 fails (too big usage of memory during upgrade)

If you give logs maybe we can help…

Sure thank you! This is the link: https://paste.yunohost.org/raw/xulidofefu

The upgrade fails after trying to update accessibility app… I am not convinced that the app is the culprit here (it is a default app) but you can always deactivate it and try to upgrade Nextcloud.

2021-09-11 21:56:28,935: DEBUG - Checking for update of app accessibility in appstore
2021-09-11 22:16:45,927: WARNING -     0/0 [>---------------------------]   0%/usr/share/yunohost/helpers.d/user: line 184:  9538 Killed 

Thanks, disabled the accessibility app and tried the update again but didn’t work…

You should check if you have enough ram+swap with

free -mh

It seems the upgrade is killed probably because you have not enough ram during the upgrade process.

how much memory does a nexcloud update need? before the update starts my yunohost vm machine is at around 30% use of memory. when I start the update process, it slowly starts eating up memory until it gets at almost 100% use, and at some point after that it fails… so the problem is not the amount of memory it seems… there is plenty of it

30% of how many ^^

free -mh

Have you a tmp partition in ram ?

df -h

30% of 16 GiB

root@yuno:/home/admin# free -mh
total used free shared buff/cache available
Mem: 15Gi 2.9Gi 3.9Gi 69Mi 8.9Gi 12Gi
Swap: 1.5Gi 706Mi 829Mi

As for the temp partition in ram, not sure, I guess so according to info below? what is that for?

root@yuno:/home/admin# df -h
Filesystem Size Used Avail Use% Mounted on
udev 7.9G 0 7.9G 0% /dev
tmpfs 1.6G 22M 1.6G 2% /run
/dev/sda1 59G 34G 23G 60% /
tmpfs 7.9G 36K 7.9G 1% /dev/shm
tmpfs 5.0M 0 5.0M 0% /run/lock
tmpfs 7.9G 0 7.9G 0% /sys/fs/cgroup
tmpfs 1.6G 0 1.6G 0% /run/user/1007

Have you something specific on your instance to declare ?
Are you able to measure the ram service by service (with htop for example) and say if it’s php7.3-fpm or mysql which grows like that…

Have you tried to disable the maximum of plugin before upgrade ?
Which kind of nextcloud plugin do you use ?

I was doing some testing so i installed a few apps… no, I have not measured the ram service by service… how do I do that?

Bwt, I have observed similar memory increases when trying to install other apps lately, which actually end up failing installation, such as languagetool or librephotos… I wonder if it’s related…