Next upgrade garradin needs php7.4

,

l’application garradin developpe une mise à jour majeure à partir de sa version 1.1.*
Cela necessite des dépendances ph7.4.
Je me suis inspiré des codes utilisés pour l’app Nextcloud quand elle avait besoin du dépôt surry avec Debian 9 pour essayer de rendre compatible cette upgrade.
J’utilise une branche 1.1 du projet créée pour tester comment upgrader la nouvelle version de Garradin: GitHub - YunoHost-Apps/garradin_ynh at 1.1
J’arrive à upgrader ou installer l’application avec php7.4 et phpfpm-7.4 pour l’instant.
Par contre, il y a une post-instalation de l’application ou in doit créer le premier utilisateur admin de l’application. Après cette étape, l’utilisateur créé n’a malheureusement pas les permissions admin et ne peux pas accéder à la configuration de l’app. Même chose pour une upgrade.
Je ne comprends absolument pas pourquoi, ni comment y rémédier…