Need Help for OnlyOffice_ynh



Have ask onlyoffice for more informations :


Well I tried to run your app, but… I don’t know how to use it from nextcloud. So I couldn’t see any errors with it with an install in a sub path.

Anyway, I still think you should try the nginx conf which has given you an error. And look at the nginx log. Especially because it doesn’t start !
I think the server part should be removed.


For use nextcloud and onlyoffice need to install onlyoffice on nextcloud !
Look :

Save and if that work you have this message :

Settings have been successfully updated


One step more work for open doc :slight_smile:


Hello !
I am currently installing OnlyOffice from git master branch. I’ll tell you the result.
Thanks @liberodark for the package. :+1::+1: (Thanks also @Maniack_Crudelis for helping him ! )
I suggest you to create an official apps topic with infos about versions and stable / testing branches (I saw there is a beta branch, maybe you could move it to a testing branch).
Best regards :grinning:


So installation is ok
Reboot is ok
Nextcloud and Onlyoffice server are running well.
but when I enter the onlyoffice server adress in nextcloud settings I have this error :

Error when trying to connect (Bad healthcheck status)

When I installed Onlyoffice, I told the page not be public, maybe thats the problem.
If it is how could I swtich this settings without reinstalling the Onlyoffice Package ?


502 bad gateway error

I’ve tried everything… could you help?


Did you make it a public page?
Can you provide log for nginx?


I encounter the same issue… I installed OnlyOffice and restarted the server, but still 502 error…


I have to tell, I installed only office in a dedicated subdomain on my server.


Ok sorry for you error 502 but is not easy to install this app
For install OnlyOffice need a CLEAN server is very important is better to your on on server for onlyoffice and one for other apps.

Best Regards