My Nextcloud cannot be restored

I moved to a new server and everything restored fine eventually. But Nextcloud, version 20.04, gives me this weird error:

2021-02-22 14:05:52,189: DEBUG - Uhoh, unknown permission nextcloud.main ? (Maybe we're in the process or deleting the perm for this app...)

I posted in github, nextcloud ynh app, but I do not think that issue tracker is very active and I am stuck…I’d like to restore my nextcloud somehow and can’t find anything about the above error. Any help is greatly appreciated.

  • Use the goddamn user support template
  • Provide the full logs. The full logs.

Sorry, I am providing the details as follows, and please don’t be so angry, I am learning:

My YunoHost server

Hardware: VPS bought online
YunoHost version: 4.1.7.2 (testing). - I have no idea why we are on testing. Is it possible to switch to stable? I installed ynh using the official documentation from the website.
I have access to my server : Through SSH | through the webadmin | direct access via keyboard / screen | …
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

As said above, I am trying to restore my Nextcloud backup config, no data. The error is simply:

2021-02-22 14:05:52,189: DEBUG - Uhoh, unknown permission nextcloud.main ? (Maybe we're in the process or deleting the perm for this app...)

So the restore fails.

There should be a full log somewhere, from the link provided after the failed restoration, or in Tools > Logs > … the failed restore operation … Then click “Share with Yunopaste”

Indeed, I just realized this and it’s a typo from tonight … no worries though, 4.1.7.2 is stable, it’s just that i forgot to replace the testing flag by stable …

Ok yes thanks. So I have 3 logs:
https://paste.yunohost.org/raw/osasezugoq
https://paste.yunohost.org/raw/ejojijafak
https://paste.yunohost.org/raw/ipusatajif

As for the stable ok great. I tried to manually edit the /etc/apt/sources.list.d/yunohost.list and added deb https://forge.yunohost.org/debian/ buster stable - can you please tell me if I should leave it as such or need to do anything else. Thanks

So the real issue is that it did not manage to create the permission. Apparently there’s an additional specific piece of log for it. Can you go to :

https://yourdomain.tld/yunohost/admin/tools/logs/20210222-130551-permission_create-nextcloud

(replacing yourdomain.tld with your domain…) and share the corresponding log ?

Well idk, that line should already be there … you should not edit anything … the fact that you see “testing” instead of “stable” is only a “cosmetic typo”

I thinks this should be https://paste.yunohost.org/raw/ucalacehal

From: https://mydomain/yunohost/admin/#/tools/logs/20210222-130551-permission_create-nextcloud

I see in that log a tromdrive domain that was a previous domain we used for nextcloud before migrating to a new one, and backing up with this new domain. Could that be a cause? Mind you, we used the new domain and all worked fine, then backedup up, then moved to a new server.

Ok thanks. If that linke is ok, since I manually added it there, then all good ;).

Uh okay not sure to understand the whole story, but I’m having an idea of what happens internally … I’ll have a deeper look and maybe release a fix which may also cover some other issues people are encountering due to the new permission system / legacy permissions

1 Like

Ok thank you very much! Looking forward to that

Hmokay so there may be a fix but it’s not trivial to know if that’s the right thing to do or not …

Anyway, in the meantime, if you temporarily re-add your own domain, you should be able to restore the app …

1 Like

Works! Thank you so much. Weird bug ha!?