Mounting borg archive fails

My YunoHost server

Hardware: Raspberry Pi at home
YunoHost version: 4.1.4.4
I have access to my server : Through SSH

Description of my issue

Running borg_ynh on a raspberry pi, backups are successfully created :+1:. Now I’d like to examine the backup archives by fuse-mounting them at some place. In principle borg can do that, but the output of a borg mount command is presently:

borg mount not available: loading FUSE support failed [ImportError: No module named 'llfuse'

I tried adding the python3-llfuse package, but it does not solve the issue. I also tried adding llfuse with pip in borg’s virtual environment but that also fails:

/opt/borg-env/bin/python /opt/borg-env/bin/pip install llfuse
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Collecting llfuse
  Downloading llfuse-1.4.0.tar.gz (478 kB)
     |β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ| 478 kB 4.4 MB/s 
    ERROR: Command errored out with exit status 2:
     command: /opt/borg-env/bin/python -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'/tmp/pip-install-d2mlx5w7/llfuse_974b8421bbac4f9490f2788fefef38f5/setup.py'"'"'; __file__='"'"'/tmp/pip-install-d2mlx5w7/llfuse_974b8421bbac4f9490f2788fefef38f5/setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);code=f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' egg_info --egg-base /tmp/pip-pip-egg-info-_d4obr0o
         cwd: /tmp/pip-install-d2mlx5w7/llfuse_974b8421bbac4f9490f2788fefef38f5/
    Complete output (4 lines):
    Package fuse was not found in the pkg-config search path.
    Perhaps you should add the directory containing `fuse.pc'
    to the PKG_CONFIG_PATH environment variable
    No package 'fuse' found
    ----------------------------------------
ERROR: Command errored out with exit status 2: python setup.py egg_info Check the logs for full command output.

Any suggestion?

I’m not familiar enough with borg, but I believe fuse may require some kernel module. Maybe you need to install some fuse-stuff using apt …

All dependencies of the debian borgbackup package are installed now (fuse itself was already there) and I recreated the python virtualenv as the install script does, but it’s still not working.

OTOH I’ve found that if I run debian’s borg package(/usr/bin/borg instead of borg_yhn’s /usr/local/bin/borg -> /opt/borg-env/bin/borg) then mounting works. Debian is installing borg 1.1.9 while borg_ynh is pulling 1.1.13, though. Maybe that’s the clue. In any case, that’s a workaround for the moment.

I’m not familiar enough with python environments to understand if it is setup as it should of if we hit some kind of bug. I guess I’ll create an issue with borg_ynh to sort this out.

borg mount depend of fuse module availability in linux kernel (if i remember well)

It’s not very efficient, i suggest you to use list and extract subcommands

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.