Monica v2.11.2 - Personal Relationship Manager


#41

Thanks @kanhu and @JimboJoe for your answers.

Indeed I am interested to use the Monica Android app. Do you know if this is possible when keeping this app private (not public) ?
I tried to connect the app with my home server but it said “bad credential”. Maybe it is impossible to connect the Android app if the yunohost app is not public.

In addition, I can’t create token for the Android app and I tried unsuccessfully to follow Monica Wiki (https://github.com/monicahq/monica/blob/master/docs/installation/generic.md) that says to run php artisan passport:install to create the access tokens required for the API.

Are you using the Android app ? How did you do to connect to your home server ?


#42

@croulibri
Have a look at this issue https://github.com/monicahq/chandler/issues/239. You can comment there to reopen the issue.


#43

Thanks for the link… I commented in the Issue app github pages
hope this issue can be solved !


#44

Maybe my problem come from the fact I can’t generate the access tokens required for the API.

On /var/www/monica/ when I make php artisan passport:install I get PHP Parse error: syntax error, unexpected '?', expecting variable (T_VARIABLE) in /var/www/monica/vendor/symfony/console/Output/Output.php on line 40

Are you able to generate the access token ?
If yes, how did you do ?


#45

@croulibri
See here https://github.com/monicahq/monica/issues/1355. But was also not helpful to me. Maybe you can see logs and find something interesting.


#46

But in that case superstrong got Encryption keys generated successfully… I am even not there as I get a PHP Parse error
So my keys are not generated. So I guess I have no chance for the API to work and so for the Mobile App to connect.

On your side, did the command artisan passport:install ran successfully ?


#47

@croulibri
You have to use php7.1.

$ /usr/bin/php7.1 artisan passport:install
I am thinking to add this line in the install script but the app was not working, so i did not.


#48

Thank @kanhu !
I got my keys… but still no Android app connection, like you :frowning: so I commented in the github of Monica.


#49

Hello @kanhu

Have you received or found any solution for using the Monica Android app. I stricly followed the instruction
I am wondering if it worth opening a new issue on the Github of Monica, indeed I am not sure if issue come from Monica itself or from the setup in Yunohost.

What is your point of view ?


#50

Hi @croulibri

I gave the error logs on the issue page. Most probably there is some thing missing or some modification needs to be done in nginx configuration. There is no official guide for nginx for the monica app. So it will be hit and trial for me, which will consume time and effort.

Its better if the monica team can provide a solution from the logs. Other solution is to ask people here https://github.com/monicahq/monica/issues/1050 , if they can use monica app with there nginx configuration and then try the working configuration with yunohost. So you can ask in the issue and then we can try that working configuration.


#51

Monica package have been updated to version 2.4.2.

Update command:

$ yunohost app update -u https://github.com/YunoHost-Apps/monica_ynh monica


#52

Bonjour,

Merci pour cet update :slight_smile:

Malheureusement chez moi cela échoue (log)

Par ailleurs, il me semble qu’il y a une petite erreur dans ta commande non ? C’est plutôt :

yunohost app upgrade -u https://github.com/YunoHost-Apps/monica_ynh monica

(et non pas update)


#53

@jln

Please keep the backup of monica under /home/yunohost.backup/archive at other safe place. The backup has your important data.

Then try to upgrade with this command.
yunohost --debug app upgrade -u https://github.com/YunoHost-Apps/monica_ynh monica

Then show the logs here.


#54

Hi,

You can get the log here.

Apparently, the main error is the follow one:

26380 DEBUG Class ‘Lahaxearnaud\U2f\U2fServiceProvider’ not found

Thanks!


#55

@jin
Thanks for the logs.

Please try to install from testing branch.

yunohost app upgrade -u https://github.com/YunoHost-Apps/monica_ynh/tree/testing monica --debug

I hope it will solve the problem.


#56

Yes it does, well done! :smile:
Many thanks :+1:


#57

Monica has been updated to version 2.4.2.

Command line install :

$ yunohost app install https://github.com/YunoHost-Apps/monica_ynh

Command line upgrade :

$ yunohost app upgrade -u https://github.com/YunoHost-Apps/monica_ynh monica


#58

App has been updated to version 2.5.0.


#59

Monica app has been updated to version 2.6.0.

Command line install :

$ yunohost app install https://github.com/YunoHost-Apps/monica_ynh

Command line upgrade :

$ yunohost app upgrade -u https://github.com/YunoHost-Apps/monica_ynh monica


#60

Monica app has been updated to version 2.7.0

Command line install :

$ yunohost app install https://github.com/YunoHost-Apps/monica_ynh

Command line upgrade :

$ yunohost app upgrade -u https://github.com/YunoHost-Apps/monica_ynh monica