Missing PHP modules



My YunoHost server

Hardware: Raspberry Pi at home
YunoHost version: 11.1.14

Description of my issue

I have backup all my system. I have re-installed Yunohost with the last version and I try to restore the apps.

  • Grav CMS is working fine.
  • Nextcloud is working fine Nextcloud complains about a lot of missing PHP modules . [edit : solved with app upgrade]
  • trss complains about missing PHP modules
PHP support for mbstring functions is required but was not found.
  • SnappyMail just displays a blank page.

I have tried a sudo apt install php7.4-zip php7.4-mbstring php7.4-XMLWriter php7.4-XMLReader php7.4-GD php7.4-cURL and also for php8.0, then reboot but messages are still exactly the same.

What am I supposed to do for fixing that ?

When I try to update the app I get an error about dependencies: https://paste.yunohost.org/raw/onepagavov


I am not a dev’ but ttrss seems to use php 8.0 :

Could you try to (re)install these modules :

sudo apt install php8.0-{mysql,curl,gd,opcache,fileinfo,intl,cli,mbstring,xml}


Thanks. I have already tried that on both 7.4 and 8.0 because the two versions are on the server but it doesn’t change anything.

What are the versions of the apps that are having issues? (Format vW.X.Y~ynhZ)

And what’s the output of sudo yunohost app info <the_buggy_app> -f | grep php ?

@tituspijean here is the output

Tiny Tiny RSS ttrss

Version: 20230107~ynh1
I tried to update ttrss but I get an error about mbstring (again). Here are the logs

sudo yunohost app info ttrss -f | grep php
admindoc: https://tt-rss.org/wiki.php
admindoc: https://tt-rss.org/wiki.php
checksum__etc_php_8.0_fpm_pool.d_ttrss.conf: 09df6cdb609764bf7805f003a890e1f5
checksum__var_www_ttrss_config.php: 8e576aeb80a68e242f540fd6493b924d
fpm_config_dir: /etc/php/8.0/fpm
fpm_service: php8.0-fpm
phpversion: 8.0

Snappymail snappymail

Version: 2.26.4~ynh1

sudo yunohost app info snappymail -f | grep php
packages: php8.0-sqlite3 php8.0-tidy php8.0-dom php8.0-intl php8.0-mysql php8.0-curl php8.0-gd php8.0-cli php8.0-xml php8.0-mbstring
checksum__etc_php_7.4_fpm_pool.d_snappymail.conf: 1eb228e7560385fccf58c3109b4c724
checksum__etc_php_8.0_fpm_pool.d_snappymail.conf: d286040a27acc43c544bcf7e9aa9fce
fpm_config_dir: /etc/php/8.0/fpm
fpm_service: php8.0-fpm
phpversion: 8.0

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.