Mise a niveau qui sepasse mal

My YunoHost server

Hardware: Raspberry Pi at home sur SSD
**YunoHost version:yunohost:
repo: stable
version: 4.0.8.2
yunohost-admin:
repo: stable
version: 4.0.4
moulinette:
repo: stable
version: 4.0.3
ssowat:
repo: stable
version: 4.0.5
I have access to my server : Through SSH
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : / yes
mise a jour par sudo yunohost tools migrations migrate en ssh
car ca ne passait pas en webadmin, il n’arrivait pas à sauvegarder mon serveur domoticz ( le msg parlait de logrotate ).
J’ai du relancer plusieurs fois l’installation pour aller jusqu’au bout, car plus de DNS ( manifestement plantage de pi-hole) , j’ai remis nameserver 8.8.8.8 dans resolv.conf pour finir l’installation avec plusieurs apt-get update & upgrade

pour l’instant; nginx ne tourne plus , ni le firewall ni hciuart.service ( commande sudo systemctl )
j’ai trouvé ce log; mais il doit y en avoir d’autres.
https://paste.yunohost.org/raw/efacoqisec

Olivier

Pas sur de savoir quel est le soucis (je lis le truc en diagonal) mais compte tenu des messages d’erreurs, perso je tenterais un modprobe nf_tables

Merci Aleks
sudo modprobe nf_tables

modprobe: ERROR: ../libkmod/libkmod.c:586 kmod_search_moddep() could not open moddep file '/lib/modules/4.19.66-v7+/modules.dep.bin'
modprobe: FATAL: Module nf_tables not found in directory /lib/modules/4.19.66-v7+

ça vient peut être de là, mais comment le réparer ? Merci d’avance :wink:

sudo systemctl status nginx
● nginx.service - A high performance web server and a reverse proxy server
   Loaded: loaded (/lib/systemd/system/nginx.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Wed 2020-11-18 12:29:22 CET; 4h 23min ago
     Docs: man:nginx(8)

Nov 18 12:29:11 olitask.changeip.com systemd[1]: Starting A high performance web server and a reverse proxy server...
Nov 18 12:29:22 olitask.changeip.com nginx[740]: nginx: [emerg] socket() [::]:80 failed (97: Address family not supported by protocol)
Nov 18 12:29:22 olitask.changeip.com nginx[740]: nginx: configuration file /etc/nginx/nginx.conf test failed
Nov 18 12:29:22 olitask.changeip.com systemd[1]: nginx.service: Control process exited, code=exited, status=1/FAILURE
Nov 18 12:29:22 olitask.changeip.com systemd[1]: nginx.service: Failed with result 'exit-code'.
Nov 18 12:29:22 olitask.changeip.com systemd[1]: Failed to start A high performance web server and a reverse proxy server.
admin@olitask:~ $ nano /etc/nginx/nginx.conf
admin@olitask:~ $ sudo systemctl status yunohost-firewall.service 
● yunohost-firewall.service - YunoHost Firewall
   Loaded: loaded (/lib/systemd/system/yunohost-firewall.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Wed 2020-11-18 12:29:21 CET; 4h 26min ago
 Main PID: 544 (code=exited, status=1/FAILURE)

Nov 18 12:29:10 olitask.changeip.com systemd[1]: Starting YunoHost Firewall...
Nov 18 12:29:21 olitask.changeip.com yunohost[544]: Vous ne pouvez pas jouer avec iptables ici. Vous êtes soit dans un conteneur, soit votre noyau ne le pr
Nov 18 12:29:21 olitask.changeip.com yunohost[544]: Vous ne pouvez pas jouer avec ip6tables ici. Vous êtes soit dans un conteneur, soit votre noyau ne le p
Nov 18 12:29:21 olitask.changeip.com yunohost[544]: Impossible de recharger le pare-feu
Nov 18 12:29:21 olitask.changeip.com systemd[1]: yunohost-firewall.service: Main process exited, code=exited, status=1/FAILURE
Nov 18 12:29:21 olitask.changeip.com systemd[1]: yunohost-firewall.service: Failed with result 'exit-code'.
Nov 18 12:29:21 olitask.changeip.com systemd[1]: Failed to start YunoHost Firewall.

je ne sais pas quelles autres infos je peux donner pour aider à la resolution du pb. Comment lancer un diagnostique en ssh ?

Uuuuuuh wokay là ça parrait super chelou car ça dit que ton serveur a oublié comment on parle en IPv4 ?

Comment tu te connectes actuellement à la machine pour taper ces commandes ?

(N.B. : prière de ne pas partir en mode “je vais tout réinstaller ce sera plus simple”, on va comprendre et réparer)

Boonsoir Aleks.
Je me connecte en ssh .
voici le ngnix.conf

user www-data;
worker_processes auto;
pid /run/nginx.pid;
include /etc/nginx/modules-enabled/*.conf;

events {
        worker_connections 768;
        # multi_accept on;
}

http {

        ##
        # Basic Settings
        ##

        sendfile on;
        tcp_nopush on;
        tcp_nodelay on;
        keepalive_timeout 65;
        types_hash_max_size 2048;
        # server_tokens off;

        # server_names_hash_bucket_size 64;
        # server_name_in_redirect off;

        include /etc/nginx/mime.types;
        default_type application/octet-stream;

        ##
# SSL Settings
        ##

        ssl_protocols TLSv1 TLSv1.1 TLSv1.2; # Dropping SSLv3, ref: POODLE
        ssl_prefer_server_ciphers on;

        ##
        # Logging Settings
        ##

        access_log /var/log/nginx/access.log;
        error_log /var/log/nginx/error.log;

        ##
        # Gzip Settings
        ##

        gzip on;

        # gzip_vary on;
        # gzip_proxied any;
        # gzip_comp_level 6;
        # gzip_buffers 16 8k;
        # gzip_http_version 1.1;
        # gzip_types text/plain text/css application/json application/javascript text/xml application/xml application/xml+rss text/javascript;


           # Virtual Host Configs
        ##

        include /etc/nginx/conf.d/*.conf;
        include /etc/nginx/sites-enabled/*;
}


#mail {
#       # See sample authentication script at:
#       # http://wiki.nginx.org/ImapAuthenticateWithApachePhpScript
# 
#       # auth_http localhost/auth.php;
#       # pop3_capabilities "TOP" "USER";
#       # imap_capabilities "IMAP4rev1" "UIDPLUS";

sinon,à part ça, domoticz et subsonic fonctionnent sur les ports 4040 et 8080 et le VPN refuse de se connecter ( la config elle n’a pas changée)

Hmoké j’ai mal interprété le message du post d’avant, j’ai confondu port 80 et IPv4 ce qui n’a rien à voir … En fait le message d’erreur fait référence à l’IPv6 (pour changer)

Du coup je sais pas trop mais naivement je tenterais de désactiver l’IPv6 sur le système et voir si ça résoud le problème :

echo 'net.ipv6.conf.all.disable_ipv6 = 1' > /etc/sysctl.d/90-disable-ipv6.conf
sysctl -p -f /etc/sysctl.d/90-disable-ipv6.conf
systemctl restart nginx
admin@olitask:/etc $ sudo echo 'net.ipv6.conf.all.disable_ipv6 = 1' > /etc/sysctl.d/90-disable-ipv6.conf
-bash: /etc/sysctl.d/90-disable-ipv6.conf: Permission denied
admin@olitask:/etc $ sudo nano /etc/sysctl.d/90-disable-ipv6.conf
admin@olitask:/etc $ cd /etc/sysctl.d/
admin@olitask:/etc/sysctl.d $ ls
90-transmission.conf  98-rpi.conf  99-sysctl.conf  protect-links.conf  README.sysctl
admin@olitask:/etc/sysctl.d $ sudo nano 90-disable-ipv6.conf
admin@olitask:/etc/sysctl.d $ sudo sysctl -p -f /etc/sysctl.d/90-disable-ipv6.conf
sysctl: cannot stat /proc/sys/net/ipv6/conf/all/disable_ipv6: No such file or directory
admin@olitask:/etc/sysctl.d $ 

les commandes ne passent pas. j’ai tenté de créer le fichier à la min mais rien.

zblerg, utilise “sudo su” pour passer en root, ensuite ça marchera

raté :pleading_face:
admin@olitask:/etc/sysctl.d $ sudo su echo ‘net.ipv6.conf.all.disable_ipv6 = 1’ > /etc/sysctl.d/90-disable-ipv6.conf
-bash: /etc/sysctl.d/90-disable-ipv6.conf: Permission denied
admin@olitask:/etc/sysctl.d $

admin@olitask:/etc/sysctl.d $ sudo su sysctl -p -f /etc/sysctl.d/90-disable-ipv6.conf
su: user sysctl does not exist

Il faut faire :

sudo su
# Puis là tu verras que l'invite de commande sera `root@tonserveur`
# *ensuite* tu tapes les commandes 'echo' et compagnie

ce n’est pas ipv6 le coupable manifestement
admin@olitask:/etc/sysctl.d $ sudo su
root@olitask:/etc/sysctl.d# echo ‘net.ipv6.conf.all.disable_ipv6 = 1’ > /etc/sysctl.d/90-disable-ipv6.conf
root@olitask:/etc/sysctl.d# sysctl -p -f /etc/sysctl.d/90-disable-ipv6.conf
sysctl: cannot stat /proc/sys/net/ipv6/conf/all/disable_ipv6: No such file or directory
root@olitask:/etc/sysctl.d# systemctl restart nginx
Job for nginx.service failed because the control process exited with error code.
See “systemctl status nginx.service” and “journalctl -xe” for details.
root@olitask:/etc/sysctl.d# systemctl status nginx.service
● nginx.service - A high performance web server and a reverse proxy server
Loaded: loaded (/lib/systemd/system/nginx.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Wed 2020-11-18 20:45:16 CET; 16s ago
Docs: man:nginx(8)
Process: 20216 ExecStartPre=/usr/sbin/nginx -t -q -g daemon on; master_process on; (code=exited, status=1/FAILURE)

Nov 18 20:45:15 olitask.changeip.com systemd[1]: Starting A high performance web server and a reverse proxy server...
Nov 18 20:45:15 olitask.changeip.com nginx[20216]: nginx: [warn] "ssl_stapling" ignored, host not found in OCSP responder "ocsp.int-x3.letsencrypt.org" in 
Nov 18 20:45:15 olitask.changeip.com nginx[20216]: nginx: [warn] "ssl_stapling" ignored, host not found in OCSP responder "ocsp.int-x3.letsencrypt.org" in 
Nov 18 20:45:16 olitask.changeip.com nginx[20216]: nginx: [emerg] socket() [::]:80 failed (97: Address family not supported by protocol)
Nov 18 20:45:16 olitask.changeip.com nginx[20216]: nginx: configuration file /etc/nginx/nginx.conf test failed
Nov 18 20:45:16 olitask.changeip.com systemd[1]: nginx.service: Control process exited, code=exited, status=1/FAILURE
Nov 18 20:45:16 olitask.changeip.com systemd[1]: nginx.service: Failed with result 'exit-code'.
Nov 18 20:45:16 olitask.changeip.com systemd[1]: Failed to start A high performance web server and a reverse proxy server.

Moké bon sinon c’est ptete l’inverse : c’est justement parce que l’ipv6 est désactivé sur ton serveur que ça marche pas …

Du coup enlevons le bidule qu’on a rajouté :

rm /etc/sysctl.d/90-disable-ipv6.conf

Et puis comme solution temporaire pour au moins relancer nginx, on peut essayer de commenter toutes les lignes du genre listen [::] (qui corresponds à l’écoute en IPv6) dans les confs nginx. Tu peux trouver tous les fichiers / lignes concernées à l’aide de :

 grep -nr "listen.*::" /etc/nginx

et les commenter en rajouter un “#” devant. Pour faire ça tu peux ouvrir le fichier nano. Par exemple :

sudo nano /etc/nginx/conf.d/tondomaine.tld.conf

ça lance un editeur de texte en terminal, tu rajoutes un “#” devant la ligne où y’a listen [::], et pour sauvegarder/quitter tu fais “Ctrl+X” (puis Y/Entrée pour valider)

ok ! Ca marche pour nginx mais il y a encore des soucis :

j’ai pas de connectivité ipv4 (pas d’adresse ip) : c’est ce que me dis l’outil de diagnostique et du coup je ne peux pas le mettre sur yunopaste. et pourtant il est accessible sur 192.168.1.72.

  '  admin@olitask:~ $ curl http://ipinfo.io/ip
    curl: (6) Could not resolve host: ipinfo.io
    admin@olitask:~ $ ifconfig -a
    eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
            inet 192.168.1.72  netmask 255.255.255.0  broadcast 192.168.1.255
            ether b8:27:eb:b8:4d:16  txqueuelen 1000  (Ethernet)
            RX packets 232378  bytes 68121187 (64.9 MiB)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 106711  bytes 22398153 (21.3 MiB)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 109775  bytes 15892242 (15.1 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 109775  bytes 15892242 (15.1 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

et systemctl me met en erreur le firewall

admin@olitask:~ $ sudo systemctl status yunohost-firewall.service 
    ● yunohost-firewall.service - YunoHost Firewall
       Loaded: loaded (/lib/systemd/system/yunohost-firewall.service; enabled; vendor preset: enabled)
       Active: failed (Result: exit-code) since Wed 2020-11-18 12:29:21 CET; 19h ago
     Main PID: 544 (code=exited, status=1/FAILURE)

Nov 18 12:29:10 olitask.changeip.com systemd[1]: Starting YunoHost Firewall...
Nov 18 12:29:21 olitask.changeip.com yunohost[544]: Vous ne pouvez pas jouer avec iptables ici. Vous êtes soit dans un conteneur, soit votre noyau ne le pr
Nov 18 12:29:21 olitask.changeip.com yunohost[544]: Vous ne pouvez pas jouer avec ip6tables ici. Vous êtes soit dans un conteneur, soit votre noyau ne le p
Nov 18 12:29:21 olitask.changeip.com yunohost[544]: Impossible de recharger le pare-feu
Nov 18 12:29:21 olitask.changeip.com systemd[1]: yunohost-firewall.service: Main process exited, code=exited, status=1/FAILURE
Nov 18 12:29:21 olitask.changeip.com systemd[1]: yunohost-firewall.service: Failed with result 'exit-code'.
Nov 18 12:29:21 olitask.changeip.com systemd[1]: Failed to start YunoHost Firewall.

je suppose qu’il y a une relation entre les deux ?
Merci beaucoup Olivier

Par curiosité, ipv6 ne serait pas désactivé dans grub ?

grep ipv6 /etc/default/grub

Quelle est la version de nginx ?

nginx -v

SI c’est 1.14.0 il y a peut être un bug dessus…

@ ljf :
admin@olitask:~ $ grep ipv6 /etc/default/grub
grep: /etc/default/grub: No such file or directory
admin@olitask:~ $ nginx -v
nginx version: nginx/1.14.2

j’ai recuperé le net en modifiant le fichier /etc/resolv.conf ( j’ai remplacé 127.0.0.1 par 8.8.8.8 ). je sais, c’est pas bien

  • Le fichier /etc/resolv.conf doit être un lien symbolique vers /etc/resolvconf/run/resolv.conf lui-même pointant vers 127.0.0.1 (dnsmasq). Si vous souhaitez configurer manuellement les résolveurs DNS, veuillez modifier /etc/resolv.dnsmasq.conf.

Quelles sont les commandes à passer pour faire ceci ?

https://paste.yunohost.org/raw/udenelawah
ps Mon firewall est toujours out
Cordialement Olivier

Alors voilà, désolé pour toi Aleks, mais après trop de bidouillages, j’ai abandonné car trop de soucis et j’ai réinstallé. Et alors là !! :astonished: :astonished: pas moyen d’y arriver ! je me retrouve avec les mêmes erreurs que lors de la mise à jour vers la 4.0 ! A savoir nginx , le firewall , "hciuart ( le bluetooth ) et dovecot dans la panade !

Bref, plus de serveur actuellement . ( j’ai un rpi 3 )

a suivre …