Mise à jour vers la version testing de Yunohost sans le vouloir

Salut,

Mon serveur YunoHost

Matériel: Raspberry Pi à la maison
Version de YunoHost: 4.2.0 (testing)
J’ai accès à mon serveur : En SSH | Par la webadmin
Êtes-vous dans un contexte particulier ou avez-vous effectué des modificiations particulières sur votre instance ? : non

Description du problème

Je viens de me rendre compte que mon Yunohost est désormais en version testing, alors qu’auparavant elle était toujours en stable.

Toutes mes mises à jour se font via l’interface en ligne en cliquant sur « Mettre à jour le système ».
Je n’ai jamais cherché à aller sur des versions autres que stables.

Questions :

  • Est-il normalement possible de passer sur du testing via cette façon de mettre à jour ?
  • Comment revenir à une version stable ?
  • Y a-t-il des risques de pertes de données en rétrogradant ?

Dans l’idée, je pense rester sur 4.2 et attendre que la version stable passe à cette version.

Merci bien !

Si c’est une installation pendant ces 3-4 derniers mois, je crois qu’à un moment l’image RPi était branchée sur testing malheureusement, désolé pour ça …

C’est pas trivial de revenir “tout de suite maintenant” sur la version stable, car downgrader c’est risqué. Néanmoins c’est relativement simple de désactiver les mises à jour sur testing : tu peux faire

nano /etc/apt/sources.list.d/yunohost.list

et enlever le mot clef “testing” vers la fin. (Sauvegarder/quitter avec Ctrl+X, Y puis entrée)

En faisant ça, tu n’auras plus de mise à jour de testing (ce qui est bien sur le long-terme, mais à court-terme on va tout de même itérer sur la 4.2 pour corriger des soucis mineurs) mais tu auras une mise à jour stable dès qu’il y aura une version stable supérieure à ta version installée

Salut Aleks,

Merci pour ton retour !
Je viens de désactiver les mises à jour testing.

En tout cas, cette version 4.2 a l’air d’être un beau changement.

Bon weekend

Hello @Thibaut et @Aleks,

J’ai eu exactement le même problème il y a quelques temps, deux semaine ou trois je dirais. J’avais pas trop le temps de m’en préoccuper donc j’ai laissé comme ça et c’est revenu en stable tout seul à une maj suivante.

Voilà voilà,
Bon week end !!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.