Mise à jour nextcloud impossible de 22.2.10~ynh1 à 24.0.4~ynh

Mon serveur YunoHost

Matériel: Raspberry Pi à la maison / Brique Internet avec VPN
Version de YunoHost: 11.0.9.9 (stable).
J’ai accès à mon serveur : En SSH | Par la webadmin
Êtes-vous dans un contexte particulier ou avez-vous effectué des modifiiations particulières sur votre instance ? : non

Description du problème

Bonjour,

La mise à jour de mon Nextcloud de 22.2.10~ynh1 à 24.0.4~ynh ne réussit pas. Je joins le log de la tentative de mise à jour car je n’ai aucune idéé du pourquoi de l’échec : https://paste.yunohost.org/raw/epeqonoveh

Merci des conseils.

Bonjour @arnauld,
je vois dans ton log les warning suivant :

2022-09-14 22:09:23,441: WARNING - The following packages have unmet dependencies:
2022-09-14 22:09:23,444: WARNING - php8.0-igbinary : Breaks: php-igbinary (< 3.2.6+2.0.8-6+0~20220131.33+debian11~1.gbp1d540e~)
2022-09-14 22:09:23,447: WARNING - php8.0-redis : Breaks: php-redis (< 5.3.7+4.3.0-1+0~20220330.42+debian11~1.gbp6fe8b7~)
2022-09-14 22:09:23,450: DEBUG - + ynh_die ‘–message=Unable to install dependencies’
2022-09-14 22:09:23,528: DEBUG - + ynh_exit_properly
2022-09-14 22:09:23,531: WARNING - Unable to install dependencies

Le problème viendrait de PHP8. Nextcloud en a besoin, mais l’installation ne se fait pas.
Essai peut-être de mettre à jour les paquets d’abord avec :

sudo apt-get update && sudo apt-get upgrade

Pour vérifier la version de PHP en cours :

php -version

6Ril

1 Like

Bon, la version en cours avec la commande “php -version” ne signifie rien.
J’étais en version 22 de Nextcloud et je viens de passer à la version 24 sans erreur.
La commande “php -version” me donne toujours php 7.4.30 (cli)

6Ril

1 Like

Je viens de retenter de nouveau la mise à jour, mais échec de nouveau :

Backing up the app before upgrading (may take a while)…

Upgrading dependencies…

E: Packages need to be removed but remove is disabled.

The following packages have unmet dependencies:

php8.0-igbinary : Breaks: php-igbinary (< 3.2.6+2.0.8-6+0~20220131.33+debian11~1.gbp1d540e~)

php8.0-redis : Breaks: php-redis (< 5.3.7+4.3.0-1+0~20220330.42+debian11~1.gbp6fe8b7~)

Unable to install dependencies

[Error] Upgrade failed.

E: Unable to locate package nextcloud-ynh-deps

As-tu essayé de faire la mise à jour manuellement, sans YUNOHOST ?
sudo apt-get update
sudo apt-get upgrade

et d’installer les dépendances manuellement :
sudo apt-get install php8.0-igbinary
sudo apt-get install php8.0-redis