Mise à jour archivist



Merci pour la mise à jour d’Archivist.
Avant celle-ci les backups s’effectuaient bien mais n’étaient pas ‘encryptés’ :

Clean old backup files
Encrypt backups

The directory “/media/storage/archivist/encrypted_backup/” does not exist. Should it be created? (y,n) Directory not created.
Unable to locate mount point, aborting.Build: encfs version 1.9.1

Usage: encfs [options] rootDir mountPoint [-- [FUSE Mount Options]]

Common Options:
-H show optional FUSE Mount Options
-s disable multithreaded operation
-f run in foreground (don’t spawn daemon).
Error messages will be sent to stderr
instead of syslog.
-v, --verbose verbose: output encfs debug messages
-i, --idle=MINUTES Auto unmount after period of inactivity
–anykey Do not verify correct key is being used
–forcedecode decode data even if an error is detected
(for filesystems using MAC block headers)
–public act as a typical multi-user filesystem
(encfs must be run as root)
–reverse reverse encryption
–extpass=program Use external program for password prompt

Example, to mount at ~/crypt with raw storage in ~/.crypt :
encfs ~/.crypt ~/crypt

For more information, see the man page encfs(1)

Sun Sep 1 02:30:50 BST 2019

Maintenant il semble que depuis la mise à jour je n’ai plus ce problème et les backups semblent bien ‘encryptés’ dans le dossier ‘encrypted_backup’. Car j’y ai bien des fichiers.

Par contre j’ai ce message :

Clean old backup files
Encrypt backups

sudo: ccrypt: command not found
Thu Dec 5 02:38:37 GMT 2019


Is the encryption what you asked for ?

About ccrypt, indeed, I added it to archivist but forgot to add it as a dependency to archivist_ynh. My bad, I’ll fix that right now.


Yes it is about encryption. Before the recent update my backups failed to be encrypted, but since the update the encryption process seems to be successful as the ‘encrypted_backup’ folder fills up with files. I wanted to let you know…

Thanks for the notice then :wink:

I’ve upgraded archivist_ynh, now you should have ccrypt as a dependency.
It would be now fixed.

Let me know if it’s not.


I now have this error message:

Clean old backup files

find: ‘/media/storage/archivist/encrypted_backup/1e,mMiW1P4NL5QnZ8PPiQr8slCXP3N9f4,jbh2N0o67fd,’: Input/output error
find: ‘/media/storage/archivist/encrypted_backup/1e,mMiW1P4NL5QnZ8PPiQr8slCXP3N9f4,jbh2N0o67fd,’: Input/output error

Encrypt backups

fuse: mountpoint is not empty
fuse: if you are sure this is safe, use the ‘nonempty’ mount option
fuse failed. Common problems:

  • fuse kernel module not installed (modprobe fuse)
  • invalid options – see usage message
    Sat Dec 7 02:44:42 GMT 2019

I don’t know about that find, but the error with mount is usual if you run the script twice.
It doesn’t affect the process though, that just because the directory isn’t yet umount.

Did you get that message from the nightly backup ? Or from a manual command line ?

From a nightly backup. I run a backup every night.

Ok, that’s strange.

Could you run mount to see if the directory is still mounted, and also have a look to the directory itself. It should be empty.
If not, try to umount it.

When I run mount I obtain this:

admin@arnauld:~ $ mount
/dev/mmcblk0p2 on / type ext4 (rw,noatime)
devtmpfs on /dev type devtmpfs (rw,relatime,size=469544k,nr_inodes=117386,mode=755)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
proc on /proc type proc (rw,relatime)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /run type tmpfs (rw,nosuid,nodev,mode=755)
tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,release_agent=/lib/systemd/systemd-cgroups-agent,name=systemd)
cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)
cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
cgroup on /sys/fs/cgroup/net_cls type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
cgroup on /sys/fs/cgroup/pids type cgroup (rw,nosuid,nodev,noexec,relatime,pids)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=29,pgrp=1,timeout=0,minproto=5,maxproto=5,direct)
mqueue on /dev/mqueue type mqueue (rw,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
sunrpc on /run/rpc_pipefs type rpc_pipefs (rw,relatime)
configfs on /sys/kernel/config type configfs (rw,relatime)
/dev/mmcblk0p1 on /boot type vfat (rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=ascii,shortname=mixed,errors=remount-ro)
/dev/sda on /media/storage type ext4 (rw,relatime)
tmpfs on /run/user/1007 type tmpfs (rw,nosuid,nodev,relatime,size=94828k,mode=700,uid=1007,gid=1007)
encfs on /media/storage/archivist/encrypted_backup type fuse.encfs (rw,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)

As expected, the directory is still mounted.
So could you try to umount it.

1 Like

Thank you for your help Maniack_Crudelis, it worked.

I unmounted the directory yesterday afternoon and the automated backup of this night completed without errors:

Clean old backup files

Delete empty directory ‘/media/storage/archivist/encrypted_backup’

Encrypt backups

Mon Dec 9 02:48:01 GMT 2019

Nice !

Check though if the directory is now unmounted, it could be an error.

Ok, so I ran:

admin@arnauld:~ $ mount | grep /media/storage/archivist/encrypted_backup > /dev/null && echo mounted || echo unmounted

It says it is mounted…

And when you use umount on it, there’s no specific error message or whatever else ?
The directory is supposed to unmount itself after 5 min of inactivity.

No, when I run
sudo umount /media/storage/archivist/encrypted_backup

I have no error message. My Yunohost set up is like this:

On a Pi with an attached hdd. I moved everything on the hdd except the boot part. So everything is on the hdd.

Hum ok.

The only thing left I can think of is to have a look to your logs. If the umount command fails, you should have something about it into your logs.

I would say syslog, but maybe another one.

Ok, thank you. I’ll have a look this week when I have time.

Ok, I’m browsing syslog.1 (for the right time and date, as syslog doesn’t record the time when cron launches archivist) but can’t find anything interesting as I don’t really know what I am supposed to look for…

Something about encfs, mount or more probably fuse.
It could as well be in other logs.

grep could help you find something.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.