Migration successful, if a little GRUBby!

My YunoHost server

Hardware: VPS bought online / Old laptop or computer / Raspberry Pi at home / Internet Cube with VPN / Other ARM board / …
YunoHost version:
I have access to my server : Through SSH | through the webadmin | direct access via keyboard / screen | …
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
If yes, please explain:

Description of my issue

I have been running yunohost on a QNAP NAS in the Virtualisation Station3 for 18 months with no ‘real’ issues. All good.

I tried the migration today to Bullseye but it failed to install GRUB. Not a YNH problem I know but I have seen others with the same issue, so something funky is happening!?

I then ran

sudo DEBIAN_FRONTEND=dialog dpkg --configure grub-pc

and the i386 of GRUB installed, I was presented with a menu to select the boot drive. /dev/vda did it for me.

The YNH WebGUI shows: Powered by YunoHost (stable).

lsb_release -a


Distributor ID: Debian
Description: Debian GNU/Linux 11 (bullseye)
Release: 11
Codename: bullseye

So the update has happened, I think.

I took a deep breath and re-booted. YNH fired up. I got my GRUB boot drive right. (/dev/vda) Whew!

  • In the WebUI system update, I have migrations 22 - 24 pending but when I click RUN nothing happens. I have attached a screen grab. How do I handle these Pending Migrations, do I just skip them? Is that safe?

I checked the PostgreSQL (psql -V) and PHP (php -v) versions and got 13.7 & 7.4.30 respectively, so I guess I can skip these.

I then ran

yunohost app upgrade -F

All the apps that I have started to update… I guess that is right?
They all updated with a “Success! APP has upgraded.”
This application(s) update took ages…

Is there anything else I should or can do to “clean up”?

So after a few hours of testing my server, I feel confident that the migration has gone well, apart from the little fight at the start with GRUB. I hope the log file helps to fix this issue in any further releases. I’m a bit of a newbie but got through it… Just.

I ran WebUI, and Diagnostics which reproduced the same results as the previous version so all good there.

All services had a big green tick!

I have a backup of my previous version, just in case, and a snapshot of this new version.

I’d like to thank all the people involved in this upgrade, you have all done a wonderful job, congratulations!!!

Very best wishes


1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.