(migration) Migration bullseye n'est pas completer

Bonjour à tous,

Je demande votre aide à la suite d’un RUN de migration de mon yunohost vers bullseye. j’ai lancé la migration vers bullseye via mon terminal et pendant l’opération l’internet à coupé. Ma connexion ssh étant coupé, ça à donc cassé la MAJ.

J’ai réussi à “réparer” la maj avec un clavier et écran à coup de dpkg et install -f, réécris la conf réseau dans le fichier interface en rajoutant ma carte réseau disparu pour retrouver le ssh ! Relancer la conf ssl car accès impossible par navigateur et réécris ma zone dns de mon registar, tout semble ok…

MAIS yunohost m’indique ceci :
Migration 0021_migrate_to_bullseye did not complete, aborting.

le paste du log ici

une idée ?

merci de votre aide !

Apparemment faudrait la log complète :

It is recommended to investigate what happened with the support team, who will need the full log of the `migration, which can be found in Tools > Logs in the webadmin.

As stated in the log:

INFO - NB: the previous migration log id seems to be 20220918-122139-tools_migrations_migrate_forward. You can share it with the support team with : sudo yunohost log share 20220918-122139-tools_migrations_migrate_forward

Désolé, j’étais bien occupé. En PJ :
log

Pour ce log, j’ai réparer l’installation. Mariadb est ok…

Sorry for not answering in French!

I had the same problem, with postinst called with unknown argument 'triggered', from your log:


2022-09-18 14:21:45,325: INFO - + Processing triggers for mariadb-server-10.3 (1:10.3.36-0+deb10u1) ...
2022-09-18 14:21:45,483: WARNING - postinst called with unknown argument 'triggered'
2022-09-18 14:21:45,590: WARNING - dpkg: error processing package mariadb-server-10.3 (--configure):
2022-09-18 14:21:45,591: WARNING -  installed mariadb-server-10.3 package post-installation script subprocess returned error exit status 1
2022-09-18 14:21:45,749: WARNING - Errors were encountered while processing:
2022-09-18 14:21:45,749: WARNING -  mariadb-server-10.3

Repairing MariaDB makes apt happy, but does not help: next time you start the migration, it breaks again.

I managed to get past the warning by breaking my system with a manual apt upgrade. Not advised :wink:

It seems to be a newly introduced bug upstream (I had the error on September 19, there is a bug report -not mine- on September 20).

Until there is news, I would leave the migration in the current state if that is workable for you!

not a problem, google traduc automatically :wink:

je viens de vérifier :

admin@didrod:~$ sudo dpkg --configure mariadb-server-10.3
dpkg: error processing package mariadb-server-10.3 (--configure):
 package mariadb-server-10.3 is not ready for configuration
 cannot configure (current status 'config-files')
Errors were encountered while processing:
 mariadb-server-10.3
admin@didrod:~$ sudo apt-get install -f
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
admin@didrod:~$ sudo dpkg-reconfigure mariadb-server-10.3
/usr/sbin/dpkg-reconfigure: mariadb-server-10.3 is broken or not fully installed

je ne vois pas quoi faire…