[Mattermost] Chat group discussion

Can I do this after installation?

Before installation I couldn’t made it public.

Sure; it should be possible from the Mattermost app settings in the Yunohost admin page. Just make the app available to “Authorized users: all users”.

Thanks @kemenaran for your help.

Now everybody has access to mattermost. But it isn’t publically accessiable. When I type my domain name into adress bar, browser shows me Yunohost Portal.

Hmm, in this case it looks more like a generic issue with Yunohost. Maybe you can try to post your issue into the general support forums? Somebody might be able to troubleshoot your issue.

Thank you very much for packing Mattermost! :smile:

I would like to use a plugin, but it seems I have to edit Mattermost’s config.json to allow plugin uploads by setting “EnableUploads” to “true”. I tried to access the app folder where I assume this file is located by FTP but get an access denied error for any app folder.

Can anyone be so kind to give me instructions on how to edit the config.json? Any hints would be greatly appreciated! To be honest I am quite new to this and have no idea how to do it through console commands. :cold_sweat:


Bad installation from GUI and CLI…

How to choose a different URL during installation ?

My yunohost config :


Could you see something wrong in the log ?



@martoni35 : you need a dedicated sub-domain, like mat.martinlencauchez.fr because your ynh is already using martinlencauchez.fr :wink:

1 Like

create new domain OK
Installation mattermost OK
Thx :slight_smile:

1 Like

This is probably because Mattermost files (under /var/www/mattermost) are owned by a different user.

I guess the best way to edit the config.json file would be to:

  1. ls -l /var/www/Mattermost, to see the user owning the files
  2. Switch to this user with su
  3. As this user, edit the config.json file with your favorite text editor
1 Like

Thank you, it worked :smiley:

Admin user logged into SSH can edit the file directly:
sudo nano /var/www/mattermost/config/config.json

hey, I just installed Mattermost on a fresh YNH server (debian 9 VPS).
Indeed it was confusing that I neeed to find in this thread that I need to login as admin.

Also, I am confused now how I can/should add users. Do I do that in YHN first and then in Mattermost? If I want to invite people directly in Mattermost I get an error that it can’t find matching team members with the email address I enter. Which is logical as there is no team… I hope to invite external people to this instance… nevermind. -> found it!

Next challenge: what do I do if people do not receive an invite email?

If people do not receive an invite email, I guess the easiest way would be to send them manually an open invitation link (you can generate one from Mattermost).

Then you can check whether Mattermost is able to send emails (for invitations and notifications). Maybe have a look at the Server logs (in Mattermost System Console), and see if you have errors about emails, or SMTP.

1 Like

I am testing the SMTP settings now, but without much luck…

Connection unsuccessful: Connection unsuccessful: SendMail: Failed to open TLS connection, tls: first record does not look like a TLS handshake

I can’t seem to locate this option. Could you give me a hint?

The invitation links can be copy-pasted from the “Invite people” dialog.

First open the “Invite people” dialog:

Then select the invitati on link, and share it to the people you want to invite:

And thanks for the error message. Indeed there is an issue when sending emails from Mattermost. Could you:

  • Check that your Yunohost instance itself is able to send emails at all (for instance from another app installed on your instance, or by configuring an email client and sending a test message to yourself);
  • Go to Mattermost System Console > SMTP tab, and send a screenshot of the SMTP configuration?

The invite screen looks different here:

And I installed wordpress, made a new user and had WP send the login credentials to me. But to no avail; WP also can’t send emails.

But here are my smtp settings:

Oh, right - you may need to enable the “Enable Account Creation” setting in the System Console to have the invitation link enabled (see https://docs.mattermost.com/administration/config-settings.html#enable-account-creation).

And about the email settings, I see you’re using an external SMTP server. In this case, Mattermost will try to reach your configured email server directly (instead of using yunohost’s own sendmail). As you’re not using Yunohost server, I can’t really help you there–you’ll have to twiddle with the SMTP settings until the right combination of passwords and TLS settings work for you.

1 Like

ok, I think I will return to the internal mail server of YNH and try to get that working. And looking at the failure of WP to send emails, I’ll have to look at YNH to solve this problem and not at the apps…

Hi there, just popping by to thank @kemenaran (and amyblais from github) for the last upgrade : it went smoothly :smiling_face_with_three_hearts:

I would love to see Matterbridge for Mattermost on Yunohost

Matterbridge is a bridge between a series of chat protocols and offers a REST-API. Supported protocols are among others IRC, XMPP, Gitter, Mattermost, Slack, Discord, Telegram, Rocket.Chat, Hipchat(via xmpp), Matrix, Steam, ssh-chat and Zulip. Minecraft servers are supported with the third party solution MatterLink.

I’ve already added it to the YH wishlist and Git . Provider Univention (similar to Yunohost) does have already a package for this.

I try to install Mattermost on Yunohost 4.1.8 (stable) running on a raspberry pi 3, without any special stuff.
Install returned error.
Here is the log error.

Here is the solution to this Mattermost installation problem : admin password should only be made with alphanumeric

J’ai essayé d’installer Mattermost avec yunohost 4.1.8 (stable) sur une raspberry pi sans aucun truc spécial.
L’installation a retourné une erreur.
Voici le log error.

Voici la solution à ce problème : le mot de passe admin doit contenir uniquement des caractères alphanumériques