Matrix-synapse login problem after upgrade to v1.12.3

My YunoHost server

Hardware: computer
YunoHost version:
I have access to my server : Through SSH | through the webadmin | direct access via keyboard / screen | …
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : yes
If yes, please explain: having a reverse proxy in front

Description of my issue

After upgrading matrix-synapse from 1.11 to 1.12.3~ynh1 Iv got SSO (single sign-on) ) as only login possibility via my Riot web 1.5.15~ynh1

I have tried moving synapse to vistors permissions and restart without any luck.
I have also uninstalled riot-web and longed in via, but get the same message.

I have looked for a solution in the forum and Iv found a possible way

`sudo yunohost app setting ID_APP skipped_uris -v "/"`

Not sure though if this is the best method, or if this is a bug?

(Note that you probably want to 'yunohost app ssowatconf' to regen ssowat’s configuration after this - but appart from this technical detail I don’t know how this app works so can’t tell if that’s the right fix for your issue)

I think that it’s the same issue than here:


yeah, that looks like the same :slightly_smiling_face:

Regarding the test branch, could I run and test or should I do something else first?

Yes, I did so and it works now :smiley:
Just run this command :

sudo yunohost app upgrade synapse -u
1 Like

Thanks guys, worked fine here too :rocket:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.