Mastodon upgrade problem

Hi fellow yunohost users

I’m running ynh4 on a 6 years old celeron based nettop (8Gb RAM/256 Gb SSD) at home.
Last week I tried the proposed mastodon upgrade, but it failed.
I tried to restore the backup but it also fails.
Th only strange thing on the seerver is that I use a symbolic link of /var/www to /home/www to get some extra space for the web applications.

There are a lot of warnings about conflicts in the log file !
By the way, a install of mastodon also fails…

the logfile is https://paste.yunohost.org/raw/ofazixiroq

Thanks fo your help !
D.

Wokay can you try to run

apt install --dry-run libpq-dev libxml2-dev libxslt1-dev  libprotobuf-dev protobuf-compiler libssl-dev libyaml-dev libreadline6-dev libncurses5-dev libgdbm-dev libicu-dev libjemalloc-dev

apt install --dry-run libpq-dev libxml2-dev libxslt1-dev libprotobuf-dev protobuf-compiler libssl-dev libyaml-dev libreadline6-dev libncurses5-dev libgdbm-dev libicu-dev libjemalloc-dev
Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances
Lecture des informations d’état… Fait
Note : sélection de « libreadline-dev » au lieu de « libreadline6-dev »
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l’impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n’ont pas encore
été créés ou ne sont pas sortis d’Incoming.
L’information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
libssl-dev : Dépend: libssl1.1 (= 1.1.1d-0+deb10u3) mais 1.1.1g-1+0~20200421.17+debian9~1.gbpf6902f devra être installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l’état ».

I removed an outdated libssl1.0.2

the new test gives :
apt install --dry-run libpq-dev libxml2-dev libxslt1-dev libprotobuf-dev protobuf-compiler libssl-dev libyaml-dev libreadline6-dev libncurses5-dev libgdbm-dev libicu-dev libjemalloc-dev
Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances
Lecture des informations d’état… Fait
Note : sélection de « libreadline-dev » au lieu de « libreadline6-dev »
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l’impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n’ont pas encore
été créés ou ne sont pas sortis d’Incoming.
L’information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
libssl-dev : Dépend: libssl1.1 (= 1.1.1d-0+deb10u3) mais 1.1.1g-1+0~20200421.17+debian9~1.gbpf6902f devra être installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l’état ».

Il y a un pbm avec libssl-dev… / There is a problem with libssl

Thanks/merci

Mokay alors faisons un :

apt install libssl1.1=1.1.1d-0+deb10u3 --allow-downgrades