Mastodon Upgrade and New Install fail seemingly due to Ruby dep but maybe permissions

My YunoHost server

Hardware: Other ARM board
YunoHost version: (stable)
I have access to my server : Through SSH | through the webadmin | direct access via keyboard / screen |
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

Yesterday I tried to upgrade to latest Mastodon version which failed. I tried to restore from the pre-upgrade backup which failed. I retrieved a backup from Borg which also failed to restore. I tried to restore through CLI after sudo su in case it was a permission issue, and that failed. Finally I tried to install new instance from scratch, and that failed. The permission error may be a red herring since I got an error about Ruby Gems availability in both attempts.

These are the logs from backup restore

These are the logs from a fresh install:

It is only social media, but I hope to be able to restore our data and fun. If you want to call, chat, or screen share with me on US Pacific time zone, hit me here on Nextcloud Talk.

Thank you for anybody who can help me out here :melting_face:

I don’t know if I’m missing the elephant in the room but all those links contain no actual logs, they only contain the metadata headers …

Yeah no logs were getting created either. Other wonky things were happening. So I rebooted the server and now I am able to restore the backup as well. So all good now over here. Thanks for your kind help as always and for helping us all live a bit more free! :grinning:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.