Mastodon install error

My YunoHost server

Hardware: VPS bought online
YunoHost version: YunoHost
I have access to my server : through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Hi everyone I get an error when I want to install mastodon from the Yunohost admin interface.

Here is the log file of installation

Meh, sorry about that, not sure why we didn’t spot this earlier …

I proposed a fix here :

I you can you can try to install the app with the fix included using :

yunohost app install

I just realize i can’t install other apps same error of the end

I try to install Mobilizon App getting same error

here is log file :

Ugh wtf why didn’t we spot this either …

Anyway, it’s indeed the same issue because it also uses yarn … So bit unlucky here

Made a fix here

You can try it with

yunohost app install

Other apps should be okay though :s

wow lucky shot i picked that app randomly to see if other applications can be installed or not :slight_smile:

did not work sir :frowning:

Hmf I was absolutely wrong about the origin of the bug and my fix was in fact un-fixing another bug. (Sorry, did all this in a rush)

Anyway … It definitely has something to do with yarn … My new guess is that yarn is already installed from debian vanilla repos, but we need a more recent version (from or whichever repo the script uses) but it doesnt upgrade to that version because of the already installed version. If that’s confirmed, that’s a tricky bug in our helpers …

I don’t know if that means anything to you but anyway, would be interesting if you can try to run (on SSH) :

apt policy yarn

And try to remove yarn (assuming it’s indeed installed) :

apt remove yarn

though be careful not to accept too fast as it may be required by something else. If that’s the case, we’ll see what’s the right way to proceed…

i tried this

apt policy yarn


      Installed: (none)
      Candidate: (none)
      Version table:

Hmmmwokay my guess was wrong again xD

What if you run 'yarn --version' ? Does it say anything ?

Can yarn cause this error because it has been deleted?


-bash: /usr/bin/yarn: No such file or directory xd

I restarted the server and now say

-bash: yarn: command not found

Should i reinstall yarn now?

Just to confirm, I’ve just installed mastodon_ynh on a fresh YunoHost and installation is working fine…

And to check yarn version, I had to first do:


And then yarn --version give me 1.22.4

@b0hem14n : soooo what if you try to run

PATH=/opt/rbenv/shims:/opt/rbenv/bin:/opt/node_n/n/versions/node/10/bin:/opt/node_n/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin yarn --version

What’s puzzling me is that the original log gives no mention of any install of yarn … Like there’s some things happening with adding the extra repo but never does apt tell about installing/configuring yarn as if it was never installed … Which seems to suggest it’s already installed somehow … But apparently it’s not ? So … x_x

@Aleks don’t need sir i think because i removed yarn and I ran installation of mastodon.It’s will work i guess process in progress atm. I will write when completed

Mobilizion successfully installed

Mastodon successfully installed

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.