Make a document recovery on a crashed yunohost

Hello to all.

I turned off my server and it won’t restart. :scream:
This is a yunohost server (version ?? recently updated ).
It’s a small 32bit eeepc laptop. I still have keyboard access.

You should know that I turned it off as part of a migration to a 64bit version on another device. However the synchronization of the nextcloud was incomplete and I have some files stuck in the 32bit yunohost.

I tried a boot repair via usb key but nothing works. it boots on grub rescue.
By unmounting the hard disk on another linux PC and also with the boot repair I can see a partition with a GRUB folder and a LOST+FOUND folder locked by a small padlock. I can’t access the files or enter my yunohost login. I tried to do a photo recovery with Foremost, but I only get thumbnails of 300*300. I think it’s because the session is not unlocked?

please how can I save the documents ? :pray: :cold_sweat:

Hi Mendiant,
I’m sorry for your loss.

My first question is : Didn’t you find your document into any of your backup ?

Second question : Do you see the /home folder on the hard drive mounted on an other computer ?


1 Like

Hi Charly.
Thanks for looking into this.
I had made a backup with luckybackup this summer but I used the hard drive by mistake to install a raspberry bone. :flushed:

I can’t see any documents and unfortunately no /home partition either.

here is a screenshot made with boot repair in live usb.

Lost+found folder is has a permission denied.

This looks like the /boot partition which is usually small and doesn’t have the “real data” on it.

Don’t you have another partition on the same disk which would be much bigger and would contain the corresponding data…?

Hello Aleks,

this is the result of Gparted. your are write :

indeed if I go to the /dev directory I have the different storage devices including sda.
However I don’t know how to access the sda2 partition and its contents.

I tried via the Boot repair file manager and via the command line, but I don’t know how to do it.

there would be a problem with sda6


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.