Main and Gandi domain does not work after router restart

My YunoHost server

Hardware: Mini PC with AMD64 processor
YunoHost version:
I have access to my server : Normally via domain and ssh
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

Hi. I use nohost domain, so my domain looks like: It works fine but I have big issue if my router will be restarted. Then I can’t access domain for about 2/3 hours. But I can connect to subdomains like:

I don’t know why is that and I need help with this problem because it is really annoying if I have power loss for a minute and then I can’t access my stuff for a long time.

Also today I bought Gandi domain and I have the same issue. I cant access my domain (I didn’t create subdomains for that domain).

that sounds weird, you can access the subdomain and you cant access the main domain?
subdomain depends on the main domain, as subdomain is just an alias on the dns server for the domain itself,

if i was in your situation what i will do is this,

first lets assume the issue is not from the hono dns servers and its your router or OS

take these steps to diagnose the source of the problem,

i assume you have a windows machine available at home, if not you can do all these steps in linux but that will be much much complicated,

so what we are going to do is we are going to test your home router with these methods,
go to
its a completely free dynamic dns service,
open an account and once you have the account ready dont do anything and DONT PICK A DOMAIN FROM dynudns!
just open an account,

then go to
its a complete 100% free domain registrar.
open an account, and then chose “register domain”
pick a name whatever you like, and it will give 4 options for free domain extensions
tk, cf, and some other i dont remember now,
click buy this domain (dont worry you dont need to pay anything it will take you to a page with drop down options “free 3months, and so on, maximum free 12 months”
follow the screen, click order once its done,
you need to insert dynudns nameservers, do it quick you have maximum 4 minutes before the freenom nameservers will be active, (in that case you will need to wait several hours till dynudns nameserver will be active)

so again, once you have completed the domain registration go to you (top bar) services > my domains > manage domains (button)

management tools > nameservers

use a custom nameserver
and fill them all with dynudns nameservers.

click change.
thats it done to have a domain of your own.

now go back to dynudns account on their website

open your account and add your new domain which you got from freenom >
just follow my screenshots

now download the dynudns windows client


install, login with your credentials and thats it, it will update your dynamic ip automatically.

in that case, now you can test instead of yunohost domain, this freenom domain with a very fast dns server response (maximum 50seconds) update.

to test the domain on your machine your’e gonna need a service what will be served in port 80 (because we assume we are using windows and not your raspberry remember?!)

the easiest way to do it is download xampp

install open xampp and enable http server,
thats it, its listening on port 80,
now go to your router, and change your router’s port forwarding from your raspberry pi to your computer (windows)
try to reach your xampp website by going to localhost on your browser if its working and you sees xampp website, now its time to trying to reach your website from the outside network
just simply set your freenom domain in the browser,

if you reach your website, ok good, now test your router what will happen if it will reboot,
if your domain doesn’t go back after 2 minutes your router is defected,
its time to replace it

if you have any questions and you do need help just leave a comment
good luck

bear in mind that can be also an issue with yunohost itself as your main domain supposed to take you to SSO so might there is a problem with sso but i dont want to go deeper into that cause i am not one of the yunohost developers they are the one who need to recommend what to do in such case,

also, bear in mind that you can always reach yunohost with your freenom domain when you set back your port forwarding to your mini pc, (sorry i just realized you have a mini pc and not raspberry pi), so you can test yunohost with it as well

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.