Mailman not archiving

We use Mailman official package.
Messages from Mailman lists should be monthly archived, but Mailman says that there is no archive since hundred posted messages for 6 months.
Is thas supposed to work ?

1 Like

I have the same problem.
I looked a bit into documentation or logs yet but did not find much. If anyone can help, that would be great!

I found this on the mailman FAQ but we are not using Apache:

Q. I can't access the public archives. Why?
A. If you are using Apache, you must make sure that FollowSymLinks is enabled for the path to the public archives. Note that the actual archives always reside in the private tree, and only when archives are public, is the symlink followed. See this archive message for more details:

I had the same issue with mailman and I solved it by changing the owner of some archives directory (as far as I can remember) to allow mailman to write in.

I’m sorry, I dit that a few months ago, I don’t remember the details


I’m facing the same issue right now.

I’m using mailman 2.1-2 on the latest yunohost.

If anyone has a proper fix, that’d be great!


I managed to fix this somehow.

The permissions that seem to be wrong is that folders for archives (in /var/lib/mailman/archives/) are owned by www-data:www-data. Well at least some of them. When making a new list, the system created archive folders owned by www-data:www-data and then when mailman receives a first message that’s supposed to be archived and wants to save it to that folder it cannot (there’s no error), unless it is owned by list:www-data (user list and group www-data)

So there are two solutions:

  • you change the owner of the folder (for example /var/lib/mailman/archives/your-new-list) to list (but not the group, group should stay www-data):
    $ sudo su
    # cd /var/lib/mailman/archives/private/
    # chown list:www-data your-new-list*
  • you add user list to group www-data. after that even if the folder is owned by www-data, user list can write to it.
    $ sudo su
    # adduser list www-data
    # service mailman restart
    (maybe it also needs a reboot)

this seems pretty hacky, and should be solved in some other way, I think. i have no idea what security consequences this has.

maybe there’s also a setting somewhere with what permissions are those archive folders created.