L'horrible histoire du méchant ssowat et du puceau / The horrible story of the evil ssowat and the virgin

Je ne code pas et ne sait utiliser un terminal que quand on me donne la procédure très précise que je ne comprends pas (et ne comprendrai jamais).
Quelqu’un m’a convaincu de l’importance de l’autohébergement, m’a parlé de Yunohost et m’en a installé un sur un VPS.
“Voici comment marche l’interface web, fais tes mises à jour et voilà!”
Pas de problème jusqu’à ce début janvier où plus rien n’est accessible.
J’appelle celui qui me l’a installé.
“Désolé, j’ai pas le temps, restore le snap et tout ira bien”
Je le fais, refais toutes mes mises à jour et le lendemain denouveau plus rien.
Je fais cela 5 fois, avec chaque fois pertes de données jusqu’à venir sur le Forum et découvrir qu’il y a un monstre nommé ssowat qui tue tout sur son passage. Je vois qu’il y a peut-être moyen de le leurrer avec une commande : curl https://install.yunohost.org/switchtoTesting | bash
Mais comment la faire? Et sans doute revenir en arrière après? Mystère et boule de gomme…
Bref, j’ai une fois encore restauré le snap, sans faire de mise à jour et je croise les doigts…
Y a-t-il eu un avertissement? Si oui, je ne l’ai pas vu ou pas compris.
Cette petit histoire pour dire que ce serait bien de trouver une manière d’avertir les puceaux qu’il y a un problème et ce qu’ils doivent faire en attendant qu’une solution soit apportée, par exemple ne pas faire de mises à jour.
Comme je ne veux pas que rouspéter, que j’aime le projet, je vais faire un petit don.

The horrible story of the evil ssowat and the virgin
I don’t code and only know how to use a terminal when someone gives me the very precise procedure that I don’t (and will never) understand.
Someone convinced me of the importance of self-hosting, told me about Yunohost and installed one on a VPS.
“Here’s how the web interface works, do your upgrades and voila!”
No problem until the beginning of January when nothing is accessible anymore.
I call the person who installed it for me.
“Sorry, I don’t have time, restore the snap and everything will be fine”.
I do it, redo all my updates and the next day nothing again.
I do this 5 times, each time losing data until I come to the Forum and discover that there is a monster called ssowat that kills everything in its path. I see that there might be a way to lure it with a command: curl https://install.yunohost.org/switchtoTesting | bash
But how to do it? And probably go back afterwards? Mystery and gumdrops…
Anyway, I restored the snap again, without updating it and I’m crossing my fingers…
Was there a warning? If so, I didn’t see or understand it.
This little story is to say that it would be nice to find a way to warn the newbees that there is a problem and what they should do until a solution is found, for example not doing updates.
I don’t just want to grumble, I like the project, so I’ll make a small donation.

1 Like

Thank you for your feedback, and sorry for the snafu about ssowat. :frowning:

Yeah, I would have gone to the support room or forum between attempt #2 or #3. :stuck_out_tongue:

You should not hide behind your newbiness. YunoHost aims to be simple and easy for non-technical users, but it also a great tool for self-learning about the great mysteries of computers and the Internets. However, your server is your responsibility, and learning the basics about maintaining it and look for help is very important. :slight_smile:

At minimum you should read our documentation, especially the page called SSH, which explains how to use the command line interface.

The general publication point for the project is here on the forum. :wink:
“Not doing updates” is not and will never be the answer. :scream:
However, I thought the issue was solved, so please report any “new” issue you might have.

You are most welcome to constructively grumble.
And thanks for your support :heart:


Thank you for taking the trouble to reply.
I’m not sure I follow you about using SSH. If we want self-hosting to be more popular, we have to face the fact that there are users who don’t have the training or the time to get into it.
But more importantly for me, I don’t think the problem is solved. If I understand this post correctly, this is a temporary way around the problem. And it’s not in my competence.
So how do I know I can do the updates without crashing?

You wrote you did not know how to perform the command to allegedly fix the issue. I am pointing you to where find that information .

Absolutely right, hence the availability of our documentation and support rooms and forum.

Then self-hosting is not for you. Server maintenance is a thing and our webadmin is not omnipotent.

It is not a temporary solution. It is the current solution for YunoHost v11.1.

We agree with you BUT we regularly explained that for now our goal in yunohost is to make self-hosting doable for about 1 person on 10 (it’s already a nice goals regarding our means). I think 1/10 can learn CLI in case of problems or issues.

And currently, if yunohost reduces the things to learn in order to selfhost, cli is still needed specifically on complex instances (with a lot of apps installed or with specific customization).

If you need something more simple, maybe you should search to host your data into a community server (if you are french speaker: see chatons.org) but there is also libreho.st or disroot.org for example.

1 Like

It would be interesting to have statistics about the current people share mastering CLI. I was unable to find any stat on this on the internet. I would approximate to:
someone using Linux (5%) = someone who knows CLI basics
Or maybe 50% of Linux Users know basic CLI or so.
Which would mean you have to get the current number of CLI users x4-x10 ? That’s a great challenge for YunoHost and the Linux World!

It is not a temporary solution. It is the current solution for YunoHost v11.1.

Unfortunately it don’t seems the solution for me
What do I have to do?

sudo curl https://install.yunohost.org/switchtoTesting | bash
[sudo] password for admin: 
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   464  100   464    0     0   4180      0 --:--:-- --:--:-- --:--:--  4180
Patching sources.list to enable testing repository...
sed: couldn't open temporary file /etc/apt/sed88mpm9: Permission denied
sed: couldn't open temporary file /etc/apt/sources.list.d/sed222OGc: Permission denied
sed: couldn't open temporary file /etc/apt/sources.list.d/sedwwDOui: Permission denied
Running 'apt-get update'
Reading package lists... Done
W: Unable to read /etc/apt/apt.conf.d/02periodic - open (13: Permission denied)
E: Could not open lock file /var/lib/apt/lists/lock - open (13: Permission denied)
E: Unable to lock directory /var/lib/apt/lists/
W: Problem unlinking the file /var/cache/apt/pkgcache.bin - RemoveCaches (13: Permission denied)
W: Problem unlinking the file /var/cache/apt/srcpkgcache.bin - RemoveCaches (13: Permission denied)
Running 'apt-get dist-upgrade'
W: Unable to read /etc/apt/apt.conf.d/02periodic - open (13: Permission denied)
E: Could not open lock file /var/lib/dpkg/lock-frontend - open (13: Permission denied)
E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), are you root?


sudo su
curl https://install.yunohost.org/switchtoTesting | bash

If it still does not work, open a dedicated support thread (fill in the blanks of the template). :slight_smile:

Thanks @tituspijean It seems better (on the terminal, not blocked any more). I’ll see how it’s on the web side

1 Like

Never say never. I have been a Windows user only since windows 3 (and msdos 5 before that, yeah, I’m feeling old). I didn’t even know that we could selfhost. And I learned about yunohost about 2 years ago (wooow, time goes fast). I tried it, broke it many times, fixed it thanks to all the people here, they helped me a lot to learn how a server works. Got detailed instructions, spent a very long time reading the forum. It took time, especially because I had a lot of responsibilities at work and with family, so I had little free time, but it was amazing to see all the wonderful things done here.
Now I have switched to my main os to Linux. I still have a lot to learn, and I’m not afraid, it will take its time.
Don’t hesitate to ask, take notes and classify them. Visit the forum often to read what’s going on. Try basic commands to understand what they are for.
Good luck :crossed_fingers: