Letsencrypt certificate install fails for new domain

,

My YunoHost server

Hardware: VPS bought online
YunoHost version: 11.0.10.2
I have access to my server : Through SSH and through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

Hello,
I would like to use subdomains and have set up the DNS records according to this site.

My main domain that I installed long ago works normally using letsencrypt, but when I install a new domain such as ‘subdomain.maindomain.com’ via the web interface, YNH cannot install the certificate. I was wondering if restarting nginx after some configuration change in the install is causing issues, here is the error log: https://paste.yunohost.org/raw/exasihudiv

I ran yunohost tools regen-conf --force and also the diagnosis reports no warnings. I checked /var/log/nginx/error.log and /var/log/nginx/subdomain.maindomain.com logs but there is nothing in there. Also yunohost app ssowatconf executes without returning anything and the metronome service is running.

Does someone have an idea how I can debug this? Thanks a lot.

I managed to fix it in the end! I didn’t find out what the issue was, but calling sudo yunohost domain cert install subdomain.maindomain.com --force from the command line worked and installed letsencrypt successfully. So nice!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.