Lets Encrypt problem

My YunoHost server

**Hardware:**ASUS EeePC 1000H (upgrade to 2GB RAM)
YunoHost version:
I have access to my server : through the webadmin and I can direct access via keyboard / screen
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

I used the .nohost.me domain name during the installation and while it works (I can connect via internet), I cannot get a proper certificate by Lets Encrypt. The Manage SSL certificate st the domain webadmin module says: "This domain doesn’t seem ready for a Let’s Encrypt certificate. Please check your DNS configuration and HTTP server reachability. ". Any thoughts?

Maybe that’s a false negative because of hairpinning issue … If you are confident that your server is accessible from outside, you can try to run from the command line :

yunohost domain cert-install your.domain.tld --no-checks

Thank you for your response!
Now the result was not successful. Alas, this forum does not let me include the link to the report I generated as the error message suggested…
Is it normal that it does not include the real name of my domain? It seems that it is trying to configure a “maindomain.tld”.
Just to note: I am not experienced with servers, first time that I try to self-host.

Yes, because the point is to anonymize the data so that not all the internet can suddenly know your domain name by just reading your post on this forum, which could lead to security issues considering the log may contain important data

Sorry about that, the spam counter-measures here are a bit harsh and we should definitely think about loosening them … But you can trick it by adding spaces in the url (or replacing dots by [dot] or whatever)

Absolutely, sorry if I already used too much slang … Yunohost is meant for people with low technical background, but as you may guess, there are also more technical people and it’s always hard to know which level of technicality to assume when adressing people :sweat_smile:

https: //paste. yunohost. org /raw/izesopinaz

Hmokay that’s weird … so Lets Encrypt complains that :

DNS problem: NXDOMAIN looking up A for maindomain.tld 
- check that a DNS record exists for this domain

Which is weird because you’re able to access your server …

What happens if you run the command 'sudo yunohost dyndns update' from command line (in SSH) ?

https:// paste.yunohost .org/raw/iqoxominab
I really appreciate your help, but I am worried that I am taking your valuable time from improving this magnificent project of yours for my killing time project! :slight_smile:
Do not worry about the slang, I consider myself technically advanced in linux and computing in general, just never cared to have a server on my own. But I cannot find any other use for my eeepc which I consider one of the best thing I bought…

Sorry, old link!
https ://paste. yunohost. org/raw/nibiniyulo

Oh my God… I just tried to connect from my android but from 4G and not the wifi and guess what, it is not there!

But when I use the https:// mydomain. nohost. me from my wifi (from the same router where the eeepc is connected) it is there… I thought I was online… I cannot understand what went wrong.

Hmwell don’t worry about this, there are more people abusing the user support for less important questions, and user support is part of the project and helps understand what are bugs in the software and what it really matters working on instead of super-advanced feature people won’t use because they can’t get the basic stuff working in the first place …

So this seem to suggest it pushed a new DNS conf … Not sure why this wasnt already done automatically but okay …

If you go to this website and put your domain name … do you see an IP address showing up ? If so, is the IP address the same as what you see on this page (from your wifi) ?

Well actually I realize I should have asked this first but : did you configure port forwarding on your router as explained in this page ?

From ip. yunohost . org :
On the first site, nothing but I am not sure I am trying correctly…
I enabled the Automatic port forwarding / UPnP option on my router.

Should I try to open them manually?

Alright … .could it be that you added multiple nohost.me domains …?

(It seems not … otherwise maybe if you share the actual domain name (in private if you want) I may be able to diagnose the issue on my side :confused: )

I just tried on mxtoolbox. com
I don’t seem to have a DNS record! :frowning:

How can I pm you?

Click on my avatar -> “Message”

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.