Les mails envoyés depuis mon yunohost sont marqués comme spam

Bonjour,

voila je viens de faire une reinstall propre de mon yunohst sur mon raspberry,

et j’utilise roundmail, mais lorsque j’envoi des mails ils sotn détecter en spam,
comment résoudre ce probléme svp ?

j’ai trouvé une log :

Received: from domaine.fr (cbl33-2-88-181-20-177.fbx.proxad.net. [XX.XX.XX.XX])
        by mx.google.com with ESMTPS id k36si2441415wrf.22.2018.01.28.00.30.38
        for <users01@gmail.com>
        (version=TLS1_2 cipher=ECDHE-RSA-AES128-GCM-SHA256 bits=128/128);
        Sun, 28 Jan 2018 00:30:38 -0800 (PST)
Received-SPF: neutral (google.com: XX.XX.XX.XX is neither permitted nor denied by best guess record for domain of user@domaine.fr) client-ip=XX.XX.XX.XX;
Authentication-Results: mx.google.com;
       dkim=temperror (no key for signature) header.i=@domaine.fr header.s=mail header.b=Wb9VhOKd;
       spf=neutral (google.com: XX.XX.XX.XX7 is neither permitted nor denied by best guess record for domain of user@domaine.fr) smtp.mailfrom=user@domaine.fr
MIME-Version: 1.0
Date: Sun, 28 Jan 2018 08:30:37 +0000
From: user <user@domaine.fr>
To: users01@gmail.com
Subject: Demo 01
Message-ID: <56be255f4720df550ff8c29b7f6fd61f@domaine.fr>
X-Sender: user@domaine.fr
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=domaine.fr; s=mail; t=1517128238; bh=47DEQpj8HBSa+/TImW+5JCeuQeRkm5NMpJWZG3hSuFU=; h=MIME-Version:Date:From:To:Subject:Message-ID; b=Wb9VhOKd8MdquWY5MBopCBbtDMG4FaVA0bs267Ol/U+Geurxh2wyRCN/aHR18S0Bd9HF7BB6fKpG5AtRso9HSxKJj43GZeepkYFeqliXXUefifpZJJI0kpVrTnR9gr/jp5rKUwQOAG8XqyAKmIGjmL4kt5OfyS8BhUGwQ6Kqvq8=

qu’en pensez vous svp ?

Il faut que tu fasses les déclarations de SPF et de DKIM pour ton nom de domaine tel que décrit ici : https://yunohost.org/#/dns_config_fr

1 Like

yes ça fonctionne merci,

j’ai ajotué des spf sur mon dns et maintenant mes mails arrive dans la boite de reception, enfin j’ai tester que l’envers des gmail pour le moment

1 Like

j’ai parlé trop vite, si je test mon serveur mx sur ce site :

https://mxtoolbox.com/

ça fait beaucoup de problème
qu’en pensez vous svp ?

Je ne suis personnellement pas trop habitué à ces résultats. Que donne un test sur mail-tester.com ?

La je suis mal :

Tu peux déplier les sujets en cliquant sur le +… on comprendra mieux ce qu’il se passe :wink:

1 Like

ça c’est amélioré tout seul,

mais c’est pas encore parfait

Ca m’embête d’avoir à te le dire mais… tu peux encore appuyer sur le + en face du problème DKIM :wink:
Tu peux vérifier également que l’enregistrement DKIM que tu as renseigné pour ton nom de domaine correspond bien à ce que te donne la commande yunohost domain dns-conf <tondomaine>.

effectivement tu as réson :

mais comment fixer ça ?

Tu n’as pas correctement renseigné l’enregistrement DKIM tel que renvoyé par la commande yunohost domain dns-conf <tondomaine>.
C’est la ligne comme celle-ci :

mail._domainkey 3600 IN TXT "v=DKIM1; k=rsa; p=uneGrannnnndeClef"
_dmarc 3600 IN TXT "v=DMARC1; p=none"