Kresus not working on YNH 11

My YunoHost server

Hardware: computer at home
YunoHost version: 11.0.5 (testing)
I have access to my server : Through SSH | through the webadmin | direct access via keyboard / screen
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : yes
If yes, please explain: YNH 11 testing

Description of my issue

I did not notice first, but Kresus is tagged as working for YunoHost 11 so I open this topic.
On my instance, the access to Kresus drive me to a page saying that I need to install Woob 3 or more recent.

So I tried to force update Kresus as it worked for other apps, but this fails with these messages :

I am on Kresus version 0.17.4~ynh1 (I think from stable, but as the testing version is the same, I am not 100% sure)

Thanks for any help

I managed to solve it myself :sunglasses:

Here is my solution, and I have no idea of if there are any yet hidden consequences, but at least Kresus works.

sudo pip uninstall virtualenv
sudo pip install virtualenv
sudo /usr/bin/python3 -m pip install --upgrade pip
sudo yunohost app upgrade kresus -F

Maybe a pip install --upgrade virtualenv would be enough, and I have no idea of the necessity of the pip upgrade, but this is what I did (plus severall try to be sure to have virtualenv removed in each pip version)

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.