Kresus me demande weboob 1.4 et ne s'ouvre pas

Mon serveur YunoHost

Matériel: VPS OVH
Version de YunoHost: 3.5.2.2 en SSH
Êtes-vous dans un contexte particulier ou avez-vous effectué des modificiations particulières sur votre instance ? : non

Bonjour,
Tout est dans le titre, la ré-instalation de Kresus me demande weeboot 1.4 ou supérieur et ne s’ouvre pas, j’ai lu les sujets similaire mais rien pour aider.
Une idée ?
@jibecfed

Please install Weboob 1.4 or later
In order to work as expected, Kresus has a single dependency called Weboob. Kresus
 could not detect a working install of Weboob (Weboob or one of its dependencies is not 
installed correctly). To offer you the best experience, the latest stable version of Weboob 
has to be installed (1.4 or later, at this point). Please contact your Kresus administrator so
 that they'll install Weboob as described in the README file: README 
1 Like

Bonjour,
Naïvement, as-tu le Weboob demandé ?

Comment vérifier ?

Le statut du paquet a l’air un peu complexe.
Tu devrais peut-être attendre l’avis d’un spécialiste qui passera par là :slight_smile:
Si tu sais ce que tu fais, tu trouveras des infos :
https://www.debian.org/doc/manuals/debian-faq/ch-pkgtools.fr.html
https://weboob.org/install
Bon après-midi !

@nayya pour installer la version 1.4 de weboob je te propose ces deux commandes, tiens nous au courant.

source "/var/www/kresus/venv/bin/activate"
pip install --upgrade weboob

j’ai ça :

(venv) admin@host:~$ pip install --upgrade weboob
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won’t be maintained after that date. A future version of pip will drop support for Python 2.7.
Collecting weboob
Using cached https://files.pythonhosted.org/packages/79/1b/2f6c8f68d982037175822872da78395b69bb0064ecb98dd3ba578ab356d1/weboob-1.5-py2.py3-none-any.whl
Requirement already satisfied, skipping upgrade: six in /usr/lib/python2.7/dist-packages (from weboob) (1.10.0)
Requirement already satisfied, skipping upgrade: requests>=2.0.0 in /usr/lib/python2.7/dist-packages (from weboob) (2.12.4)
Requirement already satisfied, skipping upgrade: python-dateutil in /usr/lib/python2.7/dist-packages (from weboob) (2.5.3)
Requirement already satisfied, skipping upgrade: PyYAML in /usr/lib/python2.7/dist-packages (from weboob) (3.12)
Requirement already satisfied, skipping upgrade: Pillow in /usr/lib/python2.7/dist-packages (from weboob) (4.0.0)
Requirement already satisfied, skipping upgrade: futures; python_version < “3.2” in /var/www/kresus/venv/lib/python2.7/site-packages (from weboob) (3.2.0)
Collecting unidecode (from weboob)
Using cached https://files.pythonhosted.org/packages/31/39/53096f9217b057cb049fe872b7fc7ce799a1a89b76cf917d9639e7a558b5/Unidecode-1.0.23-py2.py3-none-any.whl
Requirement already satisfied, skipping upgrade: cssselect in /usr/lib/python2.7/dist-packages (from weboob) (1.0.1)
Requirement already satisfied, skipping upgrade: lxml in /usr/lib/python2.7/dist-packages (from weboob) (3.7.1)
Requirement already satisfied, skipping upgrade: html2text>=3.200 in /var/www/kresus/venv/lib/python2.7/site-packages (from weboob) (2018.1.9)
Installing collected packages: unidecode, weboob
ERROR: Could not install packages due to an EnvironmentError: [Errno 13] Permission denied: ‘/var/www/kresus/venv/lib/python2.7/site-packages/Unidecode-1.0.23.dist-info’
Consider using the --user option or check the permissions.

@nayya tu dois être root pour exécuter ces commandes
admin@host:~# source "/var/www/kresus/venv/bin/activate"
admin@host:~# pip install --upgrade weboob

Ok, Kresus s’ouvre, weboob semble être à jour en 1.5 mais impossible de se synchroniser au CIC.


Importer une sauvegarde fonctionne mais aucun moyen de se synchroniser non plus.
Les 2 flèches circulaires ne sont même plus là.

C’est bon finalement, une fenêtre après la connexion empêchais l’accès au relevé de compte sur le site du cic.
Merci pour le coup de main. :+1:

Cool, content de t’avoir aidé.
Peux-tu marquer ton post comme résolu il sera peut-être utile à d’autres

I have been facing some problem with my canon printer offline windows 10 which was showing everytime so I need this to be fixed as early as possible.