Jirafeau fails to install on admin password


I am trying to install Jirafeau.

The relevant questions seem to be:

  • Choose an admin user (will be able to access admin.php page)
  • Set the password granting upload permissions (leave empty to allow
    anybody to upload)
  • Is it a public Jirafeau site?

I chose myself as admin user. I leave the password empty, 'cause I want to allow for public upload and I said yes to the question if it is a public site.

But installation goes wrong with this message:

“Downloading…Extracting…Done. Missing argument ‘upload_password’”

What can I do to allow public upload?

Unfortunately, you cant via the web administration interface.

On the CLI, you can try:

sudo yunohost app install jirafeau

Additional question: after a web administration interface installation (having defined an “upload password”), is it possible (and how?) on the CLI to change the setup in order to remove that “upload password”?

You can do so by editing two files manually:

  1. /var/www/jirafeau/lib/config.local.php and emptying the $cfg['upload_password'] array.
  2. /etc/yunohost/apps/jirafeau/settings.yml and putting an empty string for the upload_password key.

Thank you a lot, it is working :blush:

Please note that, doing it, I noticed that the “upload_password” is stored in clear in both the files you mentioned…

Yes Jirafeau is definetly laking of security… One day maybe, we will switch to coquelicot :blush:


I’m very new user of YunoHost.

I’ve tried from the CLI and it is working fine.
But install from the web admin does not work for me, I didn’t get any error message but the home page of Jirafeau stays blank.

Thanks for your help