Invalid credentials on pleroma fresh installed

I just installed pleroma on my yunohost (amd64, yunohost testing) and the installation went fine and the frontend opens normally but I cannot login with the only user created because I get this error:

Invalid credentials

This issue is quite similar to Pleroma : Invalid credentials without answers.

Another related question: where I could look for log in pleroma?

Just tested on a fresh Pleroma install, and login works with the username choosen and password provided during install.

BTW: in the, there is the commands to reset a password or create a new user

1 Like

Thank for your help but I found some problems here:

  • trying the commands written in github page I have an error

    root@noferini:/var/www/pleroma# ( cd /var/www/pleroma/pleroma && sudo -u pleroma MIX_ENV=prod mix pleroma.user reset_password leandro )
    sudo: mix: command not found

  • I can use some of these pleroma command directly, e.g. to get the link to reset the password

    sudo -u pleroma ./pleroma//bin/pleroma_ctl user reset_password leandro

  • in this way I get the link to reset the password but the new password still does not work

  • I tried also to create a new user but the command

    sudo -u pleroma ./pleroma//bin/pleroma_ctl user new prova

    does not work and ends always with this message

    Continue? [Continue?] yes
    User will not be created.

I think my problems could come from some problem with file permissions?

I really don’t know, maybe the better would be to reinstall pleroam from scratch


I had the same issue on a VM. And I fixed this issue by cleaning all cache in my brower (firefox).

I hope it might help you to fix this issue

Some way I solved the problem: the mastodon frontend works, pleroma frontend stil gives the error of “invalid credentials”.

Yes, it worked.
I tried this before but perhaps I did some error because it did not work.
Thanks a lot!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.