# Installing YunoHost on Debian 10 Fails

**URL:** https://forum.yunohost.org/t/installing-yunohost-on-debian-10-fails/19337
**Category:** Support
**Tags:** install, english
**Created:** [March 28, 2022, 11:47pm UTC](https://forum.yunohost.org/t/installing-yunohost-on-debian-10-fails/19337 "2022-03-28T23:47:32Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![micohau](https://forum.yunohost.org/letter_avatar_proxy/v4/letter/m/edb3f5/32.png) [@micohau](https://forum.yunohost.org/u/micohau)
#### Post date: [March 28, 2022, 11:47pm UTC](https://forum.yunohost.org/t/installing-yunohost-on-debian-10-fails/19337/1 "2022-03-28T23:47:32Z")

</div>

Hello,  
I am trying to install YunoHost on a fresh Debian 10 install but for the reason below it fails;

```auto
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 postfix : Depends: ssl-cert but it is not going to be installed
 yunohost : Depends: python3-requests but it is not going to be installed
            Depends: python3-lexicon but it is not going to be installed
            Depends: openssl but it is not going to be installed
            Depends: ca-certificates but it is not going to be installed
            Depends: dovecot-core but it is not going to be installed
            Depends: dovecot-ldap but it is not going to be installed
            Depends: dovecot-lmtpd but it is not going to be installed
            Depends: dovecot-managesieved but it is not going to be installed
            Depends: dovecot-antispam but it is not going to be installed
            Depends: rspamd but it is not going to be installed
            Depends: metronome (>= 3.14.0)
            Recommends: python3-pip but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
[FAIL] Installation of Yunohost packages failed

```

Anyone know how this could be fixed, I haven’t had this problem before.

---

<div class="post-metadata">

### Author: ![jarod5001](https://forum.yunohost.org/user_avatar/forum.yunohost.org/jarod5001/32/5323_2.png) [@jarod5001](https://forum.yunohost.org/u/jarod5001)
#### Post date: [March 29, 2022, 12:17am UTC](https://forum.yunohost.org/t/installing-yunohost-on-debian-10-fails/19337/2 "2022-03-29T00:17:35Z")

</div>

Try this solution ["Unable to correct problems, you have held broken packages." from fresh install on fresh Debian 10 - #3 by Juno](https://forum.yunohost.org/t/unable-to-correct-problems-you-have-held-broken-packages-from-fresh-install-on-fresh-debian-10/19308/3)

---

<div class="post-metadata">

### Author: ![friendsend](https://forum.yunohost.org/user_avatar/forum.yunohost.org/friendsend/32/5992_2.png) [@friendsend](https://forum.yunohost.org/u/friendsend)
#### Post date: [March 29, 2022, 5:29am UTC](https://forum.yunohost.org/t/installing-yunohost-on-debian-10-fails/19337/3 "2022-03-29T05:29:46Z")

</div>

Were you ever able to figure out this issue? I’m having the same problem:

> [@Unable to set Custom Webapp as default when it is installed under root domain](https://forum.yunohost.org/t/unable-to-set-custom-webapp-as-default-when-it-is-installed-under-root-domain/16414):
>
> Hi, I previously had Custom Webapp installed under [mha.fi/m](http://mha.fi/m) but i changed it to [mha.fi](http://mha.fi) without the /m but still it redirects me to the [mha.fi/m](http://mha.fi/m) when it’s installed on the root domain. Trying to set it as the default app for the domain results in a error “Unable to make ‘my\_webapp’ the default app on the domain, ‘[mha.fi](http://mha.fi)’ is already in use by ‘my\_webapp’”. Is there a way to disable this redirect so it just goes to the root domain? Thanks.

---

<div class="post-metadata">

### Author: ![micohau](https://forum.yunohost.org/letter_avatar_proxy/v4/letter/m/edb3f5/32.png) [@micohau](https://forum.yunohost.org/u/micohau)
#### Post date: [March 29, 2022, 4:08pm UTC](https://forum.yunohost.org/t/installing-yunohost-on-debian-10-fails/19337/4 "2022-03-29T16:08:36Z")

</div>

Yeah, there was a line under /etc/ssowat/conf.json.persistent with my domain, I removed it from there and it was successful.

---

<div class="post-metadata">

### Author: ![micohau](https://forum.yunohost.org/letter_avatar_proxy/v4/letter/m/edb3f5/32.png) [@micohau](https://forum.yunohost.org/u/micohau)
#### Post date: [March 29, 2022, 4:08pm UTC](https://forum.yunohost.org/t/installing-yunohost-on-debian-10-fails/19337/5 "2022-03-29T16:08:59Z")

</div>

Thanks, this worked.

---

<div class="post-metadata">

### Author: ![system](https://forum.yunohost.org/uploads/default/original/2X/f/f59fe8e3ee6b100b4f574d30d6e30479c68b89f0.png) [@system](https://forum.yunohost.org/u/system)
#### Post date: [April 28, 2022, 4:09pm UTC](https://forum.yunohost.org/t/installing-yunohost-on-debian-10-fails/19337/6 "2022-04-28T16:09:15Z")

</div>

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.
