Installing Umami - can't create Postgresql Database

Hi, thanks for YunoHost, it’s a great system!

My YunoHost server

Hardware: VPS bought online
YunoHost version:
I have access to my server : Through SSH and through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : yes
If yes, please explain: I needed a newer version of Postgresql than the one that comes with YunoHost (Postgresql 11) so I installed Postgresql 14 via SSH using apt.

Description of my issue

When I tried to install Umami the installation failed when it tried to create its Postgresql database:

2022-06-26 22:41:12,675: WARNING - postgresql-11 is not installed !?
2022-06-26 22:41:13,180: DEBUG - + ynh_clean_setup
2022-06-26 22:41:13,181: DEBUG - + true
2022-06-26 22:41:14,184: ERROR - Unable to install umami: An error occurred inside the app installation script

The full log is here:

Is there any way I can install this using my existing Postgres 14 DB and the YunoHost app installer or will I have to go to SSH and use the Umami install instructions at umami ?


Waikiki, Western Australia


If you needed just Postgresql 13 i advice you to upgrade to Yunohost 11 (bullseye version) and run the 11 to 13 migrations.

Alternative way: you can change the version in /usr/share/yunohost/helpers/postgresql helper

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.