thx for running this amazing project.
i’d like to try out mobilizon on my instance, but install fails. i wonder if anyone else has succeeded, or had the same issue?
My YunoHost server
Hardware: RPi 3B at home
YunoHost version: 4.0.8
I have access to my server : Through SSH and through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
Description of my issue
mobilizon fails to install due to dependencies issues.
the first error message reads:
2020-10-28 08:42:15,402: WARNING - E: Packages need to be removed but remove is disabled.
then below that the logs give unmet dependency errors for elixir / erlang.
can i just manually install the dependencies?
has anyone else had this issue perhaps?
[je parle français si c’est plus facile pour vous.]
EDIT: ah, it’s because it’s not (yet?) running on ARM i guess?
- can you confirm you’re trying to install the testing branch rather than the version currently available in the app store (it’s quite old … but 1.0.0 is to be merged / made available soon™)
- the dependency issue seems independent of using the current stable vs. testing … Let’s look a bit deeper by running
apt install --dry-run libwxbase3.0-0v5 libwxgtk3.0-0v5 libsctp1 erlang-mode
(it might be that there’s some dependency conflict with an already installed app)
thanks a lot for the information.
the dry run of apt install ran without error.
i was unaware of the testing issue tho, i just tried to install from the app store, unawares of the situation. i’ll try testing out soon. i also don’t mind waiting till the software is better integrated into the yuno voltron.
i poked around a little more, and it seems that elixir depends on erlang packages >= 1:22.3, but in the stable repos the current version is 1:21.2.6+dfsg-1.
the erlang-solutions.com/debian repo is enabled, but when i search for an erlang package with
apt-cache policy, the only install candidate shown is from the default raspberry pi repo…
actually i’m very confused: elixir in the erlang repo depends on packages (erlang-base, esl-erlang) that are not in the same repo and can’t be installed…
am i the only goose with this issue?
Ah yeah looking closer at the log,
elixir : Depends: esl-erlang (>= 1:22.3) but 1:22.1.6-1 is to be installed
So let’s have a look at
apt policy elixir
apt policy esl-erlang
This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.