Installing Baikal App on Debian x64 Jessie VPS

Hi there !

I recently tried to install Yunohost from scratch on my VPS (Vultr) on debian Jessie x64 and encountered no issue while installing.

So I tried to install Baikal, but there’s this error in the install log, which @kload and others helped me resolve :smile:

+ sudo chown -R www-data: /var/www/baikal
+ sudo su -c 'curl -sS | php -- --install-dir=/var/www/baikal' www-data
This account is currently not available.
+ sudo su -c 'cd /var/www/baikal && php composer.phar install' www-data
This account is currently not available.
+ sudo rm /var/www/baikal/composer.json

The error on the Baikal page was the following :

Incomplete installation

Baïkal dependencies have not been installed. Please, execute "composer install" in the folder where you installed Baïkal. 

While @kload gave me the solution, I can’t remember it. Can you please tell me what command line I should use to solve the issue ? :sunny:

Thank you!

So I could find the solution in the logs of the chat, here’s the magical command :

sudo usermod -s /bin/bash www-data

After that, uninstall the Baikal app, install it again, and everything works fine.