Installation sur Odroid N2+ (Armbian)

Mon serveur YunoHost

Matériel: Odroid N2+ 4go
Version de YunoHost: x.x.x
J’ai accès à mon serveur : En SSH et par la webadmin
Êtes-vous dans un contexte particulier ou avez-vous effectué des modifications particulières sur votre instance ? : non

Description du problème

Comme c’est un Odroid, j’ai installé la Armbian Bullseye (Odroid N2 / N2+ – Armbian)

Après avoir installé Armbian, j’enchaine sur la post install de Yunohost, je rencontre l’erreur suivante :

root@odroidn2:/# yunohost tools postinstall
Main domain: ####.ynh.fr
Admin username: eric
Admin full name: Eric
New administration password: ********
Confirm new administration password: ********
Info: Installing YunoHost...
Success! Configuration updated for 'yunohost'
Warning: parse error: Invalid numeric literal at line 1, column 6
Success! DynDNS domain registered
Success! Self-signed certificate now installed for the domain '####.ynh.fr'
Success! Domain created
Info: Updating aliases for group 'admins'
Success! Group 'admins' updated
Success! The main domain has been changed
Info: The operation 'Postinstall your YunoHost server' could not be completed. Please share the full log of this operation using the command 'yunohost log share 20230425-002205-tools_postinstall-####.ynh.fr' to get help
Error: Username already exists in the list of system users
root@odroidn2:/# yunohost log share 20230425-002205-tools_postinstall-####.ynh.fr
Error: YunoHost is not correctly installed. Please run 'yunohost tools postinstall'
root@odroidn2:/#

Doit-on installer un autre OS que Arbian ?
Comment obtenir des logs dans ce cas présent ?

Si je suis le même processus d’installation, coté web serveur, cela se matérialise de la manière suivante : je peux consulter la page générée sur l’ip locale, passer les étapes jusqu’à renseigner un domaine et un premier utilisateur, ensuite erreur.

Est-ce que cela pourrait être un problème de redirection de port ?
Ce qui expliquerait que l’on parvient à suivre le processus d’installation et à enregistrer un domaine. Mais que la communication retour cherche à se faire sur le nouveau domaine enregistré, ne parvient pas à trouver le serveur.

Il ne faut pas que le nom d’utilisateur choisi existe déjà sur le système en tant qu’utilisateur unix classique

En effet, dans Armbian, il est demandé de créer un utilisateur après avoir ajouté un mot de passe pour Root

Creating a new user account. Press <Ctrl-C> to abort

Et cette fois-ci, je n’ai pas utilisé le même nom que mon utilisateur principal Yunohost.
:white_check_mark: Donc c’était la bonne solution.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.