Installation of 2 community apps fails

I have tried installing Mattermost and Rocket.Chat and I have found the yunohost.log file that describes what is wrong with the installation of the Rocket.Chat, but I simply can’t work out what the actual problem is.

I don’t know if I made a mistake during installation, or the builds from Github fails. I have no information regarding that. I am at the moment running Nextcloud (For CalDav and CardDav) and Seafile (for file synchronisation/backup).

If you need specs on my server that is running this, I will happily supply them. At this point I just don’t see the advantage of doing so.

I thank you in advance.

Hey there,

we’ll see what we can do :wink:

Are you able to provide more logs before these lines ? I think most lines here are related to the “automatic uninstall after install failure” (such that the system stays ~clean)

I would love to. Do you have any idea what logs could be useful?

I think the same log you already shown (just ze need the lines before it), so /var/log/yunohost/yunohost-cli.log

I apologise for the odd look of the log, but that was the easiest w

ay to me :slight_smile:

So, the relevant part is Unable to install the app in that location.

This could be due to the fact that you have an app installed on the root (i.e. '/') of this domain ? Is that the case ?

Edit: you can easily investigate this by running : yunohost app map

It shows 2 apps:
servername/nextcloud: Nextcloud
servername/seafile: Seafile

Also, I am quite sure that I ask it to install it in a folder called “rocketchat”.

Yes indeed, that should work :confused:

Can you try to run : yunohost domain url-available your.domain.tld /rocketchat, see if that returns True or False ?

If it returns False, I suspect the setting system is in some weird state… So maybe you can try to run grep -nr "^path:" /etc/yunohost/apps/*/settings.yml to dig into it

Something tells me that this has started to make less sense. I don’t know if it matters, but Yunohost is running on Hyper-V on Windows Server 2012 with one dedicated CPU core and 4096MB RAM.

Well after looking closely at it, I think it’s actually a bug in the rockechat app/package …

I uses checkurl here with

yunohost app checkurl $domain -a $app

but it should be

yunohost app checkurl $domain$path -a $app

So either

  • the app is meant to be installed on a full domain (i.e. no other app on the domain) but given the rest of the script I doubt it
  • this bug was not spotted because all people who tried the app so far installed it on a full domain (or a domain with no installed app already)

So if you want a quick work around, I think you can run :

  • git clone
  • Edit rocketchat_ynh/scripts/install to add $path after $domain the use of “checkurl”
  • Install the app via yunohost app install ./rocketchat_ynh

And we can/should also report the issue on Github :wink:

I have changed the line under #Check domain/path availability
to: sudo yunohost app checkurl $domain$path -a $app

Now it says: Error: Unknown app

I have experience with the usage of terminals, but I have no clue what causes this.

You mean when you run yunohost app install ./rocketchat_ynh ?

When running this command, you should make sure that you’re in the appropriate folder, such that when you run ls you see a folder named rockechat_ynh

(Basically what we did here was to clone the app in a local folder, change the script, then now we want to install it from this local folder ;))

I really thank you for your patience. I was indeed in the wrong folder. I have been met by new errors though… :frowning:

How do I remove all previous attempts?

Uh, that looks weird ? Isn’t there any lines before these ?

Unfortunately not. I was however met with an error message when I logged in to the web administration, and then clicked on “Applications”. I wonder if they are related?

A screenshot of what that error looks now after I rebooted the server:

Hm okay, that really looks weird because that sounds like the app is really in a broken state (not installed and kind installed at the same time) whereas normally when the install fails, it automatically removes files that were copied and configuration stuffs.

If right now you re-run the install of rocketchat and it fails, it should automatically run the remove script, but given your previous screenshot (from yesterday) I believe that’s not enough ?

One dirty solution though, could be to go into /etc/yunohost/apps and remove the rocketchat folder with rm -rf rocketchat (or some other name depending of the exact name of the folder). Then re-attempt an install :s

I just tried force removing it, and installing it with cloning from github. I edited the install script file, and I still seem to be shown the “rocketchat_ynh seems to be incorrectly installed” when trying to install it. So something is on my server. Is there anyway to search for such a thing?

I have 3 things installed, and none of them even supports MongoDB. Could a removal of that particular package have any interest?

Hm I don’t think so :confused: YunoHost understands that an app is installed because of the existence of files in /etc/yunohost/apps/nameoftheapp.

Can you confirm that you removed the folder named rocketchat but still get the message about rocketchat being “incorrectly installed” when attempting to install it ?

That I can confirm and verify.

I just double-checked.