Installation de Mastodon impossible


#21

Here you are, thanks @kanhu !
https://paste.yunohost.org/ivotewoyap.sql


#22

Visiblement la branche develop est en mouvement mais l’installation échoue toujours. Des informations ?


#23

Je me permet un petit up :slight_smile:
J’obtiens toujours des erreurs que ce soit sur la branche master ou la develop

Log master: https://paste.yunohost.org/raw/luhasunosu
Log develop: https://paste.yunohost.org/raw/onovofehek

En espérant que quelqu’un pourra m’aider :slight_smile:

Merci d’avance


#24

L’app Mastodon m’intéresse aussi et j’avais été bloqué en essayant de l’installer il y a quelques temps.
Je vais réessayer sur une installation propre, on peut partager sur le salon xmpp:apps@conference.yunohost.org?join ou IRC pour aller plus vite dans le debuggage.


#25

Pour la traçabilité, le commit https://github.com/YunoHost-Apps/mastodon_ynh/commit/95745611d4dd81ba87e2da36f4ce59875f475c2d permet de débloquer une bonne partie de l’installation.

Chez moi je bloque maintenant sur la version NodeJs :

[12541.1] + ynh_exit_properly
[12541.1] sh: 1: node: not found
[12541.1] + local exit_code=1
[12541.1] Webpacker requires Node.js >= 6.0.0 and you are using 4.8.2
[12541.1] + '[' 1 -eq 0 ']'
[12541.1] Please upgrade Node.js https://nodejs.org/en/download/

bien que ynh_install_nodejs 8 soit demandé en début d’install.
NB : l’installation des dépendances Debian fait installer nodejs en version 4.8.2; j’ai tenté de mettre ynh_install_nodejs 8 après l’installation des paquets Debian pour éviter que la version par défaut soit écrasée mais ce n’est pas mieux.


#26

Je désespère de voir la future MAJ :disappointed_relieved:
Alors je souhaite juste un bon courage aux devs qui se démène pour débugger mastodon_ynh :hugs:
Merci.


#27

dans l’attente également, bon courage et merci pour le travail!