Install on top of yunohost v1


I was running yunohost v1 perfectly on debian squeeze. I’ve just updated to debian wheezy and tried to update also to yunohost v2.
My problem is now in post install step. I think there is maybe an issue since some packages are the same than on v1.
When I try to do yunohost post install I have an error after giving new password.
Certificates are generated but then I have the message Invalid password.
I’m wondering if it has to do with ldap since I may have previous ldap data from v1.
Actually, there is not a lot of thing I’d like to keep from v1. It would be great if I could keed ttrss DB. It’s ok if I have to clean old data except ttrss.

Thanks for your support. You can answer in french if needed.

Main domain: mydomain.tld
New administration password:
Confirm new administration password:
Installing YunoHost…
Generating a 2048 bit RSA private key
writing new private key to ‘/usr/share/yunohost/yunohost-config/ssl/yunoCA/ca/cakey.pem’

Updating certificates in /etc/ssl/certs… 0 added, 0 removed; done.
Running hooks in /etc/ca-certificates/update.d…
Error: Invalid password

You should reinstall YunoHost v2 and migrate your data such as rss feeds. You can migrate them by following that documentation.

What do you mean exactly by reinstall yunohost v2 ?
I’ve tried launching the install script several times with same result and also apt-get purge some packages without success.
I’m in the case of Install on Debian since I don’t want to start from scratch.
Is there any useful tips to understand what happens and how to fix my system.
I think I can debug looking at some logs, i’m proficient on Debian distribution.

I mean reinstall from scratch because those 2 version are incompatible.

I have the same problem on my server. I was not upgrading from yunohost v1 but I had a Debian installed with fusiondirectory, a ldap already initialized.
Any clue to debug this issue would be fine because all my attempts to install it through the USB keys failed.

Where are the log?
It looks that there is nothing interesting in /var/log/yunohost for postinstall script

What does this error mean ?
My password is not inlined with an already chosen password, which one.
Or the password update starts and then fails …

Thanks for your support and help.
From a high level point of view, Yunohost is THE project I’m waiting for years.



I finally managed to make it “kind of work” without reinstalling Debian but it’s not perfect and I still have errors I would need to investigate.
To be honest I don’t really know how I did.
My idea was to apt-get purge requirements of yunohost v2 and manually delete data like LDAP ones.
I have installed yunohost v2 on another VM from scratch to be able to compare a working install vs. my updated install.
You can try to do something like this but it’s long and not perfect.