Impossible d'installer Framaforms

:fr:

Mon serveur YunoHost

Matériel: Brique Internet avec VPN
Version de YunoHost: 3.7.0
J’ai accès à mon serveur : En SSH | Par la webadmin
Êtes-vous dans un contexte particulier ou avez-vous effectué des modificiations particulières sur votre instance ? : non

Impossible d’installer Framaforms

A partir de l’interface d’installation des applications, j’ai souhaité installer Framaforms. J’ai donc cliqué sur “Install” et voilà les étapes affichées sur la page (dans l’ordre dé-chronologique) :

Could not complete the operation 'Install the 'framaforms' app'. Please provide the full log of this operation by clicking here to get help

Removing the dedicated system user...

'/etc/php/7.0/fpm/conf.d/20-framaforms.ini' wasn't deleted because it doesn't exist.

'/etc/php/7.0/fpm/pool.d/framaforms.conf' wasn't deleted because it doesn't exist.

Removing php-fpm configuration...

Removing nginx web server configuration...

Removing app main directory...

Removing dependencies...

Removing php...

connection to server was lost

before or while processing the request.

This probably means the server terminated abnormally

server closed the connection unexpectedly

FATAL: arrêt des connexions suite à la demande de l'administrateur

Removing the database...

Loading installation settings...

Removing the app following the installation failure…

Could not complete the operation 'Install the 'framaforms' app'. Please provide the full log of this operation by clicking here to get help

Could not install framaforms: An error occurred inside the app installation script

/usr/share/yunohost/helpers.d/logging: line 11: args_array: readonly variable

Unable to update core dependencies with Composer.

ynh_composer__2: line 8: 24907 Killed COMPOSER_HOME="$workdir/.composer" php${phpversion} "$workdir/composer.phar" $commands -d "$workdir" --quiet --no-interaction

Installing Composer...

Creating Drush alias...

Configuring system user...

Configuring nginx web server...

Setting up source files...

Creating a PostgreSQL database...

Installing dependencies...

Installing PHP7.3...

Storing installation settings...

Validating installation parameters...

Installing the app 'framaforms'…

Le log complet est présent ici :
https://libre.nohost.me/zerobin/?555057593e96ebe4#bXFe52Lnq0rIdRfcVH+f1uzfnDoS62jnv3GmSPhbxtk=

Est-ce que les caractères spéciaux du mot de passe a pu créer cette erreur : présence des caractères ‘]’, ‘)’, ‘?’, ‘@’

Merci par avance :slight_smile:

Ca semble indiquer que le process s’est fait sauvagement tué par le kernel, probablement car pas assez de mémoire …

Est-ce que tu saurais dire si tu as déjà beaucoup de choses installées ?

Je n’ai pas grand chose d’installer.

J’ai donc ré-essayé et là l’installation a fonctionné… Je ne saurai l’expliquer. (entre temps j’ai redémarré la brique internet).

J’obtiens néanmoins l’information suivante, que je transmets à la communauté :

/!\ Packagers! This app is still using the skipped/protected/unprotected_uris/regex settings which are now obsolete and deprecated… Instead, you should use the new helpers ‘ynh_permission_{create,urls,update,delete}’ and the ‘visitors’ group to initialize the public/private access. Check out the documentation at the bottom of yunohost.org/groups_and_permissions to learn how to use the new permission mechanism.

Néanmoins, je remarque que la disposition (mise en page) ne respecte pas ce qui est, je pense, prévu. En comparant avec le site https://framaforms.org/, c’est comme si j’obtenais cette même page mais sans l’activation du javascript de https://framaforms.org/. Est-ce normal ?

Salut à tous,

Est-ce que vous savez comment transmettre le warning pour les gestionnaires de paquets ? L’erreur obtenue a été la suivante :

Concernant la mise en page qui n’est pas correcte pouvez-vous m’indiquer comment rectifier le tir ?

Merci par avance pour votre aide :slight_smile:

Salut à tous,

Avez-vous un retour concernant la mise en page qui est foireuse sur ynh ? Si non, puis-je ajouter ici les copies d’écran des rendus des applications entre l’application Framaforms sur YNH et le site https://framaforms.org ou, pouvez-vous créer un ticket sur le projet Microsoft / Github https://github.com/YunoHost-Apps/Framaforms_ynh ?

D’avance merci :slight_smile:

Oui, ça aiderait à y voir + clair dans ce qui cloche

Merci @Aleks, ta participation à nos différentes demandes est très appréciables, merci ! :slight_smile:

A-t-on une idée des fichiers JS qui seraient manquants ? (en supposant que l’erreur vient de là puisque résultat identique lorsque l’on bloque le JS avec le greffon NoScript sur le site de référence).

Beh du coup je comprends pas ce qui marche pas exactement x_x Tu veux dire que quand tu clique-glisse le bidule “nombre” ça marche pas ? Est-ce que tu peux regarder dans la console JS si y’a des erreurs potentiellement ? (Oublie les machins liés au theme de yunohost, c’est connu)

Ou sinon regarde si avec un autre navigateur ça fait pareil, ce qui pourrait indiquer que c’est une extension qui bloque des trucs …

Ne vois-tu pas la différence visuelle ? ou peut-être est-ce normal ?

Le rendu du site “normal” ressemble à ça : https://libre.nohost.me/lufi/r/s5iFwdDbWx#qrerdDRuU8XkhIH24PE5BZhXn+uEUeC8bdWjCpSQy7I=

Non, juste la page d’accueil qui ne semble pas correctement ordonnée.

Oui, j’ai bien testé avec un autre navigateur et pareil, l’erreur est la même :frowning:

C’est fait (je suis d’après le manifest de l’app le packager officiel de cette app)…

Il me semblait avoir corrigé ce problème visuel, mais je crois qu’entre temps les sources corrigées ont été modifiées… Bref une régression.

Ok, très bien :slight_smile:

Ah ok. De mon coté, le problème semble être le Carousel qui ne fonctionne pas. Je me trompe ?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.