Impossible d'installer etherpad

,

Bonsoir,

Chaque tentative d’installer cette appli se solde par un échec, et j’ai du mal à décrypter le debug (visible ici).

Bonjour @stemy2

Je remarque que tu es encore en jessie. Peut-être qu’une première étape serait de migrer à stretch https://yunohost.org/#/jessie_stretch_migration

Pour https://github.com/YunoHost-Apps/etherpad_mypads_ynh tu peux peut-être mettre ton traceback là bas dans une “issue”. Je vois aussi qu’il y a du mouvement sur ce dépot donc il semble être maintenu. Ou peut-être tu tombe sur un bug qui vient d’être introduit.

Looks like there was an error during the installation of the plugin ep_countable, could you please share the log /var/log/etherpad_mypads/installation.log ?

https://stemy.me/zerobin/?81d74a1485718e99#xdwgZnwwBj1kwU+MktjHkLsWOH+Wn1fXewqR5lxeAVs=

npm ERR! file /root/.npm/ep_countable/0.0.7/package/package.json
npm ERR! code EJSONPARSE

But the version 0.0.7 is from 2016. So it can’t be an error from the plugin.

Can you please run df -h ?

As you can see it below, my disks are far from full. Why do you ask me this question ?

root@stemy:~# df -h
Filesystem      Size  Used Avail Use% Mounted on
udev             10M     0   10M   0% /dev
tmpfs           100M   13M   88M  13% /run
/dev/mmcblk0p1   30G  4.0G   25G  14% /
tmpfs           249M     0  249M   0% /dev/shm
tmpfs           5.0M     0  5.0M   0% /run/lock
tmpfs           249M     0  249M   0% /sys/fs/cgroup
/dev/sda1       230G  193G   26G  89% /mnt/HDD
tmpfs            50M     0   50M   0% /run/user/0

Because that’s a common error, especially with a blank file as a result.
Also, with a default partitioning, you would have a too small /tmp.
Can you retry to install? I can’t see any reason for this plug-in to fail to install.

This is not the plugin, the install fails even if i uncheck the box «install plugins».

I just tried again, it failed again.

Is it failing with the same error ?

Yes, it does.

I’ve really no idea why this plugin is still failing to install. One thing you can do is to clone the repository, comment the line for this plugin in the install script and retry to install.

As i said before, this is not the plugin’s fault.

Have you read the log and understood it ?

Try to do what I’ve told you… So we could see if the install script can go further.

Actually, i didn’t understood the log.

Oddly enough, four years later, I think I ran into the same problem. It has a bug here: Installation can not be finished on Yunohost · Issue #135 · YunoHost-Apps/etherpad_mypads_ynh · GitHub

removing plugins from install solved this indeed: GitHub - felagund/etherpad_mypads_ynh: Etherpad MyPads package for YunoHost

But I do not know where to go from there.

The logs are here: https://paste.yunohost.org/raw/womefutezu

judging from the comments above, that is exactly the same problem as OP’s