[Impossible de mettre à jour le cache APT]

Mon serveur YunoHost

Matériel: Odroid N2.
Version de YunoHost: 4.0.7 (stable)
J’ai accès à mon serveur : En direct avec un clavier/écran
Êtes-vous dans un contexte particulier ou avez-vous effectué des modificiations particulières sur votre instance ? : Routeur synology RT2600ac + VPN FDN (IPV4 et V6 fixe) + Freebox (routeur en DMZ)

Lorsque je clique sur “mettre à jour le système” dans la page d’admin de Yunohost, il est indiqué :

Impossible de mettre à jour le cache APT (gestionnaire de paquets Debian). Voici un extrait du fichier sources.list qui pourrait vous aider à identifier les lignes problématiques :
sources.list:deb http://deb.debian.org/debian buster main contrib non-free
sources.list:deb http://deb.debian.org/debian buster-updates main contrib non-free
sources.list:deb http://deb.debian.org/debian buster-backports main contrib non-free
sources.list:deb http://security.debian.org/ buster/updates main contrib non-free
sources.list.d/openhab2.list.save:deb https://dl.bintray.com/openhab/apt-repo2 stable main
sources.list.d/tvheadend.list.save:deb https://www.deb-multimedia.org buster main non-free
sources.list.d/syncthing.list:deb https://apt.syncthing.net/ syncthing stable
sources.list.d/nextcloud-devs-ubuntu-client-groovy.list:deb http://ppa.launchpad.net/nextcloud-devs/client/ubuntu groovy main
sources.list.d/yunohost.list:deb http://forge.yunohost.org/debian/ buster stable
sources.list.d/armbian.list.save:deb http://apt.armbian.com buster main buster-utils buster-desktop
sources.list.d/openhab2.list:deb https://dl.bintray.com/openhab/apt-repo2 stable main
sources.list.d/docker.list.save:deb [arch=arm64] https://download.docker.com/linux/debian buster edge
sources.list.d/docker.list:deb [arch=arm64] https://download.docker.com/linux/debian buster edge
sources.list.d/tvheadend.list:deb https://www.deb-multimedia.org buster main non-free
sources.list.d/yunohost.list.save:deb http://forge.yunohost.org/debian/ buster stable
sources.list.d/nextcloud-devs-ubuntu-client-groovy.list.save:deb http://ppa.launchpad.net/nextcloud-devs/client/ubuntu groovy main
sources.list.d/armbian.list:deb http://apt.armbian.com buster main buster-utils buster-desktop
sources.list.d/syncthing.list.save:deb https://apt.syncthing.net/ syncthing stable
sources.list.d/plex.list.save:deb https://downloads.plex.tv/repo/deb public main
sources.list.d/plex.list:deb https://downloads.plex.tv/repo/deb public main

Est-ce qu’il y a une ligne que je devrais enlever ou, au contraire, une que je devrais rajouter ?

Merci beaucoup

Salut,

C’est difficile à dire comme ça. Ça raconte quoi lors de la mise à jour du cache justement?

Bonjour Kayou,

Comment je mets à jour le cache (parles tu de apt update && apt upgrade ?) ?

Excuse la question d’un débutant :slight_smile:

Seulement sudo apt update pour mettre à jour le cache (sudo apt upgrade c’est pour mettre à jour les paquets de ton système).

Aucun souci, on a tous été débutants à un moment!

Output de apt update :

Atteint :1 https://www.deb-multimedia.org buster InRelease
Atteint :2 http://deb.debian.org/debian buster InRelease
Atteint :3 https://downloads.plex.tv/repo/deb public InRelease
Atteint :4 http://security.debian.org buster/updates InRelease
Réception de :5 http://deb.debian.org/debian buster-updates InRelease [51.9 kB]
Réception de :6 http://ppa.launchpad.net/nextcloud-devs/client/ubuntu groovy InRelease [24.3 kB]
Ign :7 https://dl.bintray.com/openhab/apt-repo2 stable InRelease
Réception de :8 https://dl.bintray.com/openhab/apt-repo2 stable Release [6,051 B]
Atteint :9 https://download.docker.com/linux/debian buster InRelease
Atteint :10 http://forge.yunohost.org/debian buster InRelease
Réception de :11 http://deb.debian.org/debian buster-backports InRelease [46.7 kB]
Atteint :13 https://apt.syncthing.net syncthing InRelease
Atteint :12 https://imola.armbian.com/apt buster InRelease
Err :6 http://ppa.launchpad.net/nextcloud-devs/client/ubuntu groovy InRelease
Les signatures suivantes n’ont pas pu être vérifiées car la clé publique n’est pas disponible : NO_PUBKEY 60EE47FBAD3DD469
Réception de :15 http://deb.debian.org/debian buster-backports/main armhf Packages.diff/Index [27.8 kB]
Réception de :16 http://deb.debian.org/debian buster-backports/main arm64 Packages.diff/Index [27.8 kB]
Réception de :17 http://deb.debian.org/debian buster-backports/main armhf Packages 2020-09-17-0805.03.pdiff [1,030 B]
Réception de :17 http://deb.debian.org/debian buster-backports/main armhf Packages 2020-09-17-0805.03.pdiff [1,030 B]
Réception de :18 http://deb.debian.org/debian buster-backports/main arm64 Packages 2020-09-17-0805.03.pdiff [1,024 B]
Réception de :18 http://deb.debian.org/debian buster-backports/main arm64 Packages 2020-09-17-0805.03.pdiff [1,024 B]
Lecture des listes de paquets… Fait
W: Erreur de GPG : http://ppa.launchpad.net/nextcloud-devs/client/ubuntu groovy InRelease : Les signatures suivantes n’ont pas pu être vérifiées car la clé publique n’est pas disponible : NO_PUBKEY 60EE47FBAD3DD469
E: Le dépôt http://ppa.launchpad.net/nextcloud-devs/client/ubuntu groovy InRelease n’est pas signé.
N: Les mises à jour depuis un tel dépôt ne peuvent s’effectuer de manière sécurisée, et sont donc désactivées par défaut.
N: Voir les pages de manuel d’apt-secure(8) pour la création des dépôts et les détails de configuration d’un utilisateur.

Err :6 http://ppa.launchpad.net/nextcloud-devs/client/ubuntu groovy InRelease
Les signatures suivantes n’ont pas pu être vérifiées car la clé publique n’est pas disponible : NO_PUBKEY 60EE47FBAD3DD469

Voilà l’erreur, je ne sais pas pourquoi il y a ce dépôt là. Le plus simple c’est de commenter cette ligne à mon avis, mais voyons voir si il y a des paquets installé avec ce dépôt:

Que donne cette commande?

cat /var/lib/apt/lists/ppa.launchpad.net_nextcloud-*_Packages

Output :
zsh: no matches found: /var/lib/apt/lists/ppa.launchpad.net_nextcloud-*_Packages

Donc normalement commenter cette ligne (ajouter un # devant) dans le fichier /etc/apt/sources.list ne devrait pas poser de problème, et solutionner le tien :slight_smile:

Merci beaucoup Kayou.
C’est fait dans /etc/apt/sources.list.d/nextcloud-devs-ubuntu-client-groovy.list
:slight_smile:

Bonne après-midi

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.