Impossible de mettre à jour l'adresse IP sur DynDNS

What type of hardware are you using: Raspberry Pi 3, 4+
What YunoHost version are you running: 12.1.40.1 stable
How are you able to access your server: SSH

Describe your issue

Bonjour,
Je suis newbie dans la gestion serveur, je vous présente mes excuses si, malgré mes recherches, le problème avait déjà été exposé.
Je finalise l’installation de mon serveur mais je ne parviens pas à effectuer les dernières validations pour le domaine. J’ai systématiquement des erreurs à ce niveau. En SSH, ça me dit “the peer didn’t know the key we used” et “Could not update IP address to DynDNS” lorsque je tente de forcer la mise à jour.
Je suis chez Free, si cela peut être utile à préciser. J’ai accès en SSH et peux m’en servir, mais comme je maitrise mal, il est possible que je n’aie pas lancé la bonne commande ou quelque chose comme ça. En tout cas, je ne sais pas quoi faire, ni trop comment avoir plus d’information ^^
Merci beaucoup pour votre aide !
PS : j’écris en français mais je peux lire en anglais, je ne maîtrise pas assez le sujet et j’ai peur qu’un message en anglais ne soit pas clair ^^

Share relevant logs or error messages

the peer didn’t know the key we used"
“Could not update IP address to DynDNS”

https://paste.yunohost.org/raw/ehodakamem

Bonjour,

j’allais écrire un sujet mais je crois avoir le même problème. Suite au reset de mon domaine, j’ai pu ajouter un mdp de récupération, le clé a bien été créée dans /etc/yunohost/dyndns et le cron ajouté.

Mais lorsque j’ai voulu faire sudo yunohost dyndns update j’ai aussi eu cette erreur : ERROR - The peer didn’t know the key we used

Bonjour,

J’ai le même type d’erreur suite à la réinstallation d’un de mes serveur.

Ayant oublié le mot de passe d’enregistrement du domaine principal, je suis passé par la web-admin afin d’en saisir un nouveau, d’enregistrer le changement, de faire une sauvegarde et de la télécharger via la web-admin pour réinstaller le serveur.

Tout a été restauré mais depuis j’ai ce type de mail adressé à root :

objet : Cron root@domaine : YunoHost DynDNS update; sleep $((RANDOM%60)); ! ping -q -W5 -c1 ipv4.yunohost.org >/dev/null 2>&1 || test -e /var/run/moulinette_yunohost.lock || yunohost dyndns update >> /dev/null

ERROR The peer didn’t like the signature we sent
ERROR Could not update IP address to DynDNS

J’ai modifié le cron pour éviter d’avoir le message toutes les 10 minutes.

sudo yunohost dyndns update --force [sudo] password for toto :
Info: Update needed, going on…
Error: The peer didn’t like the signature we sent
Info: The operation ‘Update the IP associated with your YunoHost subdomain ‘domaine.ynh.fr’’ could not be completed. Please share the full log of this operation using the command ‘yunohost log share 20260809-155338-dyndns_update-domaine.ynh.fr’ to get help
Error: Could not update IP address to DynDNS

ppr

Bonjour,

J’aime les problèmes partagés ^^ Est-ce que cela fonctionnait normalement avant les resets de vos serveurs respectifs ? Est-ce que vous aviez paramétré quelque chose du côté du FAI ?

Merci et bonne journée !

Bonjour, de mon côté j’avais un autre problème, l’ipv6 a changé (ipv4 ok), en voulant faire l’update j’ai vu qu’il manquait les clés dans /etc/yunnohost/dyndns. C’est un vieux compte sans mdp de récupération et ça buggait en essayant d’en ajouter un.

Depuis peu j’ai eu un reset, j’ai pu ajouter un mdp, refaire le subscribe mais c’est l’update d’ip qui bug cette fois.

J’ai vu cette erreur plusieurs fois sur le forum, j’espère qu’il y aura une solution, croisons les doigts :wink:

Bonjour,
J’ai des problèmes similaires aux tiens ! J’ai installé yunohost cet après midi en choissant un domaine ynh .fr

Bonjour tout le monde,

un problème similaire avec des échanges qui pourraient peut-être vous intéresser : Problème DynDNS nouvelle installation

De mon côté je continue à faire un peu n’imp’ en attendant de voir si ça marche (là la nouvelle surprise : je n’arrive plus à me connecter en SSH) :melting_face:

Bonne soirée !

Problème résolu ici :

@Horus_rouge @ppr @zz99, comme évoqué par Padrys cela devrait être résolu. Pardon pour le bug et le retard dans son traitement.

@Horus_rouge n’hésite pas à passer le sujet en Résolu si c’est tout bon maintenant.

Bonjour,

C’est tout bon, merci merci beaucoup ! :smiley: