I can open admin interface, but not user interface

Hi,

Hardware: Beelink S2
YunoHost version: 3.6.4.3

I just installed YunoHost on a Debian server, and (since it is a freshly installed instance) I am not in a special context and I did not perform any particular tweaking on it.

I have access to my server through SSH and through the webadmin, but there’s no way to access the user interface.

Even though everything seems fine in theory (this tool tells me the right ports are open, I have configured my DNS as recommended on the Domains page and I have created several users and installed several apps) clicking the User interface button tries to open the User Interface, but fails to do so.

I only get an “ERR_CONNECTION_TIMED_OUT” message from my browser telling me to check my proxy and firewall.

Also, opening my domain and opening my public IP do the same.

Is there any way that I can fix the issue? Thanks!

Hello,
It does, however, look like a DNS resolution problem.
Maybe just wait for the propagation of your DNS changes.

How long should that take? It’s been like eight hours since I configured it, but the problem persists.

It may not come from there too!
Check out: https://www.whatsmydns.net/
Have you thought about clearing your browser’s cache?
Sorry for my English :smile: www.deepl.com

According to that tool, the DNS have already propagated:

And yet, the client doesn’t load. So it’s probably something else?

Oops,
Sorry, I don’t really have any more ideas.
Hairpinning?
Status SSO / Nginx?
IPv6 / IPv4
https://yunohost.org/#/users

From what I can diagnose using your domain and IP :

  • DNS config seems to be okay (at least for the A record, which is what matters right now)
  • However, trying to reach the IP in a web browser tends to indicate that port forwarding is the issue, as port 80 redirects to nothing (Unable to connect) and 443 redirects to some router config page (I guess, as the certificate is from Technicolor or whatever)

Sooo, gotta double check that port forwarding configuration …

I’m guessing that you’re using the local IP address when doing all those tests, right ?

No idea, but I could test those.

How can I do that? The only way I know is this tool, and it says everything’s fine.

I use the local IP to open the webadmin, and yes, it also seems to use the local IP to (try to) open the user interface when I click the blue button. But if I use the public IP I get the same result: the browser tries to load, then gives up after a while.

Have you tried hard :
yourdomain.tld?

Yes, with the same results.