Home Assistant on Subdomain

Home Assistant can only installed with a separate Domain.

I have a domain registered and used on a commercial webspace for my email. There I added a subdomain.
I added this subdomain on my yunohost instance. Then installation worked.

Now if I click on “Home Assistant” on my Yunohost Portal, it redirects me to this subdomain, but not to the Home Assistant instance on my Yunohost server.

What do I not understand?
I guess it’s got something to do with the dns configuration - at least.

Did you set the root for the domain from the app settings?

1 Like

And if you think that’s todo with the DNS Then show us what you are thinking, ever heard of a screenshot. Next time you already should have them ready because we cant see in your brains so there is also de diagnostics have you run that?

Sorry to barge into here but you are not being very helpful with the others are you? If you really mean to be helpful then I would suggest ease it a bit down yeah? Here, have some gin and tonic!

1 Like

Standard domain is a noho.st domain.

Diagnostic screenshot:

Just changed the zone record of the new subdomain from to

I guess now I have to wait 24h to test it.

i dont drink thats for people with real problems ahaha but don’t mind me being direct that s our culture :wink:

Have you set all the values correctly and what is you TTL at?

Which values do mean exactly?

What does “what is you TTL at?” mean?

And: it’s a real problem. Been running this yunohost server for more than a year and have multiple servers in the meantime.
But I’m not an IT-Pro.

TTL the amount of minutes which it refreshes or the change actually wil happen

1 Like

No idea - thats why I wait 24h now before I try next things.

AFAIK dns is updated at least every 24h generally.

What is the number value 300? that’s minutes so calculate a minute to that number or ask siri or ask your provider. 24 hours seems way to long since then if you ip changes your unreachable for 24 hours that is disastrous

1 Like

Now I probably found what you mean: The TTL value in my providers cPanel is for this new subdomain 14400. Weird, that means 240h - can’t be somehow.

I run the diagnosis test on my yunohost server again: still the same problem. So I wait till tomorrow I guess.

It’s only a subdomain, no problem if it not reachable. But thanks for the hint.

Edit: Just noticed, that I can change that value on cPanel - changed it to 10.
So I’ll try in 11 minutes if it works.

Now the diagnosis sais it’s okay.

But as I expected, by pressing the button “Home Assistant” on my yunohost panel, it redirects to the subdomain and not to the home Assistant installation on my yunohost server.

What is the installation path of the app that is shown in the web admin ? Is it shown/installed correctly there?

1 Like

@HoldMyGin prarrot :stuck_out_tongue:

The path is empty.

Adding homeassistant results in a 404.

Could you send a screen of what you are adding? and what path is empty? installation path cannot be empty either a value like / or /homesomething

It was / rhen I changed it to /homeassistant
Undone it as it didnt help.