Help needed with SSO CSS files

#1

Hi, i was attempting to follow the guide to “rebrand” my yunohost installation to make it look more professional and such … but when i changed the BASE64 image code to a custom image, the menu stopped loading. all together and i’m not sure how or why that happened. do i need to “regenerate” the menu somehow? i made sure i didn’t mess any of the CSS up. i’ve only edited the single logo image as seen here: https://i.postimg.cc/Kz1Cc6xy/Screen-Shot-2019-04-17-at-17-25-40.png

proof ynh_overlay.css is still intact: https://i.postimg.cc/SKhWxC4Q/Screen-Shot-2019-04-18-at-14-51-25.png

#2

Well uh, not sure to know what happens exactly … but maybe looking at the debugger with F12 could help ?

#3

head and body tags are just blank. i restored the css file and it still doesn’t work… i don’t know what happened. there’s a yunohost command to restore various parts, is there a command to restore the SSO? … or well, the panel over lay?.. the normal SSO panel works fine. the overlay is blank for some reason. apparently its not the files themselves because i just restored them… and i don’t think its the permissions because i edited them, i didn’t overwrite anything and its all owned by root in the first place. can you verify my issue by changing the images in /usr/share/ssowat/panel/assets/css and see if it still works for you? i’ve “broken” two separate installs the same way and don’t know what’s wrong.

#4

i’ve even now downloaded the entire /usr/share/ssowat folder from a working install and uploaded it to the broken install and the overlay still doesn’t work.

#5

just want to make it clear that the panel itself works perfectly fine and continues to do so. its just the overlay that is broken.

#6

Are you in a multidomain context ?

#7

Well if you’re using a custom theme, it should just be a matter of removing the theme line in /etc/ssowat/conf.json.persistent …

#8

im not… i didn’t change /anything/ except the css file with the picture in it. i didn’t touch any themes or anything.

and about multi domain, no… there is only one domain with multiple subdomains.

#9

Well when dealing with themes, if you follow the instructions, you are not supposed to edit the original files from SSOwat but copy them to create and enable a new theme …

Now if you want to get back the original files, maybe try to apt install ssowat --purge --reinstall

#10

i followed the “rebranding” directions. it didn’t really mention anything about themes. is there a link to these “themes” instructions? they seem exactly what i’m looking for, i hope.

#11

that command didn’t work. might be possible that nginx is the issue. is there a command to set the nginx configs to default without having to reinstall all the applications again? our IT person might’ve changed a header or two but i wouldn’t know in which file.

#12

Well I dunno what directions you followed … this supposedly is the only piece of doc on the matter : https://yunohost.org/#/theming

#13

thank you! the one i followed was a forum post, not a page like this. thank you.

#14

still having an issue with the SSO overlay… after using a different browser [safari shows the grey screen, but chrome seems to display a legitimate error “login.mothnet.xyz refused to connect.” and if you remember i also had set mothnet.xyz to “default site” for my email server and login.mothnet.xyz to my sso login website. would that cause the issue? or maybe something else?] its not a forbidden… so its not permissions… i see the error in an iframe of “yunohost/sso/portal.html”