HedgeDoc post-install error - Config panel question 'allow_anonymous' should be initialized during install

My YunoHost server

Hardware: VM in ProxMox, at home
YunoHost version: 11.1.22
I have access to my server : Through SSH + through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
If yes, please explain:
If your request is related to an app, specify its name and version: HedgeDoc v 1.9.8~ynh2

Description of my issue

I am trying to install HedgeDoc. Just a simple default install to try it out. (I already run some other apps successfully on this instance of yunohost.)

I selected mostly default installation options. Particulars:

  • my yunohost root domain
  • the path ‘/hedgedoc’
  • access group ‘all yunohost users’

The default for the access group option was ‘visitors’. The hint text for it was something like “enabling this option will…” which suggests to me that it used to be a boolean option and perhaps hasn’t been filly updated to be a selection of a group name instead.

After install:

An error prevents the configuration panel from being displayed:

Config panel question 'allow_anonymous' should be initialized with a value during install or upgrade.

Please report this error to the YunoHost team to get it fixed!

after install

does that mean that the install was succesfull?

Can you share the full install logs?

allow_anonymous should have been initiated to false at install in /var/www/hedgedoc/config.json file. (ligne 12)

Thank you for taking an interest! The HedgeDoc app installed successfully, and can be opened and used, but because of this error the config panel can’t be accessed.

Installation log: https://paste.yunohost.org/raw/sijazojefi

Some additional debugging that I tried, without being too sure what exactly is relevant:

$ sudo yunohost app config get hedgedoc 
Error: Config panel question 'allow_anonymous' should be initialized with a value during install or upgrade.
$ sudo yunohost app setting hedgedoc allow_anonymous
false
$ sudo yunohost app setting hedgedoc allow_anonymous_edits
false
$ sudo grep -i anonymous /var/www/hedgedoc/config.json
        "allowAnonymous": false, 
        "allowAnonymousEdits": false,

Also I should declare: when I first tried the installation, the installation failed on a network error (while trying to fetch a package from nodejs.org); it then proceeded to do a “Remove HedgeDoc after a failed installation” which apparently went smoothly (the log for that is shown as successful). Then, after that, is when I ran the install again and got the reported problem. So it’s possible that the problem could be related to improper clean-up in this sequence. I haven’t attempted to reproduce the problem on a fresh YunoHost.

Thanks.

I just now tried again got the same result when installing HedgeDoc on another instance of YunoHost (same versions of Ynh and HedgeDoc), where I don’t think HedgeDoc had ever been installed before.

Hmmm well given this, this seems to be a bug in the core rather than the app package … Maybe related to the fact that it’s false :thinking:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.