Google flags my sites as dangerous (Deceptive site ahead)

,

hope I don’t jinx myself but for about a 2/3 weeks now ive not had issues after doing this which someone above posted but now seems to be gone?

anyway use these link

  1. https://search.google.com/search-console
  2. https://postmaster.google.com/
    add your domain to both links by google and then go to security under search console then click on fixed enter some random malarkey then wait for it to happen again in few days but by then you should be hopefully good with google and might have to do the malarkey once more and hope that works.

but i dont know yet if google will still red flag me again but so far no issues.

1 Like

Would have agreed with you but then I logged in this morning and bam… Back again.

Do you reckon it’s worth doing a coordinated campaign against google? Setup some tickets then get everyone here to jump on and comment. While that is going start a Twitter campaign #googleisbeinga**** (Or something more polite)?

Just as an update:

  1. I’m unable to use Google’s search-console because I am using a stock ynh.fr domain. As such, I have no access to my domain’s DNS records.

  2. Adding a My_Webapp page and setting it as the default – both as domain.tld/site and at the domain root (domain.tld/), and even with a customised HTML splash page explaining it’s a private server run for a family – made the situation worse. Before, VirusTotal said only Google Safebrowsing thought my domain was a phishing site. Immediately after, I had 2 extra companies think so, and “multiple redirects” was the reason given, as before.

  3. I submitted a request for review here (Report Incorrect Phishing Warning) as I said in my previous post, but so far there’s been no change.

I second what others have said about customising the SSO login screen. I know it has been mentioned in passing that it is possible using custom style sheets (CSS) and/or Javascript, but I’m sure I’m not the only one who would really appreciate a step-by-step guide on how to actually do this in the context of a Yunohost server. Not everyone is a web developer.

You could also try asking Google Webmasters for help directly, Google Search Central Community

As another update, I have done the following and now have 7 companies in total marking my ynh.fr domain as “phishing” or “malicious”.

  1. Modified the blue “Please sign in to see this content” box that appears above my server’s SSO login fields, so that the text says, “This is a private server for a family’s own use. We aren’t phishing anyone.”
    For anyone else who wants to do this, edit the file /usr/share/ssowat/portal/locales/en.json (or if your locale is French: fr.json), and look for the line that begins with "please_login:".
    For example: "please_login": "Here is some sample text",
    Keep the quotation marks and the comma on the end. Save & exit.
    Check that nginx is still OK by running: sudo nginx -t
    Then either reboot your server (sudo reboot now) or restart nginx (sudo systemctl reload nginx)

  2. Followed the instructions here to add robots.txt to the root of the domain.

Strangely VirusTotal gives different results if you type https:// on the front of the URL. It also has results for subdomains I no longer have.

Right, some success.
I realised that the report I made to https://safebrowsing.google.com/safebrowsing/report_error/?hl=en-US hadn’t gone through because of a browser extension I was using, so I turned it off, tried again, and within a few hours, Google Safebrowsing had stopped marking my domain as phishing/malicious.

I have also been writing to the other companies in the VirusTotal analysis results to either flag up my domain as a false positive, or ask them to review it. You can either contact them in the normal ways or use the ‘report false positive’ feature that some of their websites have. Of the 8 that were marking it as phishing/malicious yesterday morning, I’m now down to 2. :slight_smile: